Your message dated Tue, 06 Mar 2018 15:49:39 +0000
with message-id <e1eteqr-0004wp...@fasolo.debian.org>
and subject line Bug#884880: fixed in devscripts 2.18.1
has caused the Debian Bug report #884880,
regarding [uscan] Please clarify that spaces in debian/watch "opts" are only 
valid in version 4
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
884880: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=884880
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: lintian
Version: 2.0.0
Severity: normal

Hello,

I'm getting a lintian warning an the package ltp:

W: ltp source: debian-watch-file-should-mangle-version

however, the watch file in question actually does mangle the version on the line

opts=dversionmangle=s/\+.*$// \
http://sf.net/ltp/ltp-full-([0-9]+)\.tgz debian git-import-orig

which correctly changes 20081031+dfsg to 20081031.

Regards
   Jiri Palecek

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 2.6.24.3-test-pcw (SMP w/1 CPU core; PREEMPT)
Locale: LANG=cs_CZ, LC_CTYPE=cs_CZ (charmap=ISO-8859-2)
Shell: /bin/sh linked to /bin/dash

Versions of packages lintian depends on:
ii binutils 2.18.50.20080812-1 The GNU assembler, linker and bina ii diffstat 1.45-2 produces graph of changes introduc ii dpkg-dev 1.14.22 Debian package development tools ii file 4.21-1 Determines file type using "magic" ii gettext 0.17-2 GNU Internationalization utilities ii intltool-debian 0.35.0+20060710.1 Help i18n of RFC822 compliant conf ii libdigest-sha-perl 5.47-1 Perl extension for SHA-1/224/256/3 ii libparse-debianchange 1.0-1 parse Debian changelogs and output ii libtimedate-perl 1.1600-6 Time and date functions for Perl ii liburi-perl 1.35-2 Manipulates and accesses URI strin
ii  man-db                2.5.2-2            on-line manual pager
ii perl [libdigest-sha-p 5.10.0-13 Larry Wall's Practical Extraction

lintian recommends no packages.

Versions of packages lintian suggests:
pn  binutils-multiarch            <none>     (no description available)
pn  libtext-template-perl         <none>     (no description available)
ii  man-db                        2.5.2-2    on-line manual pager

-- no debconf information


--
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/



--- End Message ---
--- Begin Message ---
Source: devscripts
Source-Version: 2.18.1

We believe that the bug you reported is fixed in the latest version of
devscripts, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 884...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Mattia Rizzolo <mat...@debian.org> (supplier of updated devscripts package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Tue, 06 Mar 2018 16:23:00 +0100
Source: devscripts
Binary: devscripts
Architecture: source
Version: 2.18.1
Distribution: unstable
Urgency: medium
Maintainer: Devscripts Maintainers <devscri...@packages.debian.org>
Changed-By: Mattia Rizzolo <mat...@debian.org>
Description:
 devscripts - scripts to make the life of a Debian Package maintainer easier
Closes: 811565 834006 841519 855464 884604 884880 885917 886211 887380 888307
Changes:
 devscripts (2.18.1) unstable; urgency=medium
 .
   [ Yavor Doganov ]
   * ltnu:
     + Add pkg-gnustep shortcut.  Closes: #885917
 .
   [ Steve Langasek ]
   * tests:
     + Fix test_debchange when run on Debian derivatives.  Closes: #886211
 .
   [ Mattia Rizzolo ]
   * bts:
     + Fix syntax issue in the POD documentation, so it can be built with an
       older pod as well.
   * ltnu:
     + Avoid using L<> with emails in the POD documentation, so it can be built
       with an older pod as well.
   * reproducible-check:
     + Instruct to install python3-xdg if missing.  Closes: #888307
   * mk-origtargz:
     + Split list of files to delete if the list gets too long to fit ARG_MAX.
       Thanks to Ximin Luo <infinity0> for the initial patch.  Closes: #855464
   * debian/control:
     + Change maintainer email from alioth to devscri...@packages.debian.org.
     + Move the Git repository to salsa.debian.org.
 .
   [ Osamu Aoki ]
   * uupdate:
     + bash completion fix by Julian Gilbey.  Closes: #834006
   * uscan:
     + clarify importance of version=4.  Closes: #884880
     + add hrefdecode option.  Closes: #884604
     + git HEAD tracking features.  Closes: #811565
     + refine target directory documentation.  Closes: #841519
     + add test for FTP protocol.
 .
   [ James McCoy ]
   * debrepro:
     + Add a --help option and include options description in the usage output.
 .
   [ Axel Beckert ]
   * ltnu:
     + Add option "-m" to only look in the Maintainer field and not also in
       the Uploaders field.  Closes: #887380
 .
   [ Christoph Berg ]
   * origtargz: Make --clean remove .gitignore if it's not in git.
 .
   [ Benjamin Drung ]
   * Fix all pylint3 issues.
   * Update Python unittests to support pylint 1.8.
   * Convert flake8 test into a unittest.
Checksums-Sha1:
 b27945882858b9c4913ad6c6740d8a4219898606 2604 devscripts_2.18.1.dsc
 7861dc201a1e305ab7e27b08383d16b5866b1f2c 720156 devscripts_2.18.1.tar.xz
 38ad448932821132b21324a0f3bed264e1aacd36 10581 
devscripts_2.18.1_amd64.buildinfo
Checksums-Sha256:
 f656e18984620e61a9455a658fe90c3359d312bd4c597e521b7de27b6d25275e 2604 
devscripts_2.18.1.dsc
 96886bf5d6605a619a12d56b9af5eb354106bf754d9b0fd562fbcbb2bf7b5ef9 720156 
devscripts_2.18.1.tar.xz
 bc816958592acf631a8745d97b5c209f1e070496508b212241c38a8184a80842 10581 
devscripts_2.18.1_amd64.buildinfo
Files:
 66e61971fb68e7bb1eab5c2d4ebb2ab0 2604 devel optional devscripts_2.18.1.dsc
 9a6170ea36baf43225777f677def184a 720156 devel optional devscripts_2.18.1.tar.xz
 2c89076c69ec6f0b4b65770552e1efbf 10581 devel optional 
devscripts_2.18.1_amd64.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEi3hoeGwz5cZMTQpICBa54Yx2K60FAlqesygACgkQCBa54Yx2
K63RPQ//Z9oZyE3iT1f2i3MXW/1aCaCQSrnx9FM7EGtz3gRydPUhYoygpGncrmUM
GZ8f0fyJonks1PXNAgVY6zMYBco9iwdBnNHpv1g7tDv+b6p7j/7Eav8M8sCyMVJ6
jivhM/UHbbVhxXsWW7a3w4VPYF7NJwD5nPnpCs9GT6nvelTR4u1Ourc+tZ2XnoNM
MlwRhc+PMPD832LJr3HXnnC4XbeWAY4UQIlfUGvSok511MAsyTejKHLP0/Z7q5lS
B1I9owHuCUpwuOhA+pMgM3ExYyN9r+m2zN6fX3YSo9uy0wniTx4zQpN1LbilWymr
ipgp1DDhn8cSnVtRZf5ki//BBg9HmmFEQKLYRejxiZfx/OxvymuhnfBPRjJT4DBc
PS6oGzJSzkYAvNUghss752f52s3TmdTtHnaO/rEwAyXYeTSzkBxApvd3Dc9+Pfbt
J0MsKnqcJ/39Tnf54LGXMSLmj6z+uezE8zckERYMEF/3BnDPK6Le/3Y49YM46sqm
ebJJWaIHq3/H62GJzQlGqoZZC8WMQeWpfU+fLk8mexTQ535hXlpJb7ChV4EOwadS
YE6Zv977EKRdUIYkvndTcSkAa6DlYFCDmy7UwXPZZfm+eEbtzblhw/uEVFqyllGA
GxSYdhxgM/hIpDyDnpFl4vc26SH9jvlKfHyvRypL6o/d3uU37xw=
=mxQW
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to