Your message dated Sun, 11 Mar 2018 16:30:40 +0100
with message-id <>
and subject line Re: Bug#813729: libimlib2: unable to load gifs after loading 
another image
has caused the Debian Bug report #813729,
regarding libimlib2: unable to load gifs after loading another image
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: libimlib2
Version: 1.4.7-1+b1
Severity: normal


When using imlib_load_image_with_error_return repeatedly in the same
process, it is unable to load gif images and returns
IMLIB_LOAD_ERROR_NO_LOADER_FOR_FILE_FORMAT instead. This does not happen
for the first call, only for subsequent ones, though not necessarily for all
file orders. However, when it does happen, it is 100% reproducible.

This bug was found while investigating a build failure in feh, which runs
load tests for various file formats. See the following program for a minimal
demonstration of the issue:

In theory, any of "./imgif test/ok/jpg_exif test/ok/jpg",
"./imgif test/ok/gif" and "./imgif test/ok/jpg_exif test/ok/jpg test/ok/gif"
should work fine, since they are all loading the same files, just in different
orders. However, since 1.4.7, the last one fails reproducibly.

libimlib2 version 1.4.6-2+b3 in Debian 8.3 is not affected by this issue.

Many thanks to Peter Pentchev for tracking down this issue to imlib2
and creating the imgif test program. See
for the original report.


-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.3.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages libimlib2 depends on:
ii  libbz2-1.0       1.0.6-8
ii  libc6            2.21-7
ii  libfreetype6     2.6.1-0.1
ii  libgif7          5.1.2-0.2
ii  libid3tag0       0.15.1b-11
ii  libjpeg62-turbo  1:1.4.2-2
ii  libpng12-0       1.2.54-1
ii  libtiff5         4.0.6-1
ii  libx11-6         2:1.6.3-1
ii  libxext6         2:1.3.3-1
ii  zlib1g           1:1.2.8.dfsg-2+b1

libimlib2 recommends no packages.

libimlib2 suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
On Sat, 10 Mar 2018 20:43:25 +0200 Peter Pentchev <> wrote:
> So, yeah, sorry for the confusion; the current versions of imlib2 and
> giflib look fine from here, too.  Thanks for your work!

Thank you both for the confirmation! I'm going to close this bug report now.



Attachment: signature.asc
Description: OpenPGP digital signature

--- End Message ---

Reply via email to