Your message dated Tue, 13 Mar 2018 08:18:30 +0100
with message-id <a2d50d45-e411-6eef-7a65-2b08c81e4...@debian.org>
and subject line Re: pillow: Bad Build-Depends for stretch
has caused the Debian Bug report #888419,
regarding pillow: Bad Build-Depends for stretch
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
888419: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=888419
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: pillow
Version: 5.0.0
Severity: normal

Dear Maintainer,

I get:
root@:~# apt-get build-dep pillow
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 builddeps:pillow : Depends: python-olefile but it is not installable
                    Depends: python3-olefile but it is not installable
                    Depends: libraqm-dev but it is not installable
E: Unable to correct problems, you have held broken packages.

However:

root@:~# apt-get check && echo ok
Reading package lists... Done
Building dependency tree
Reading state information... Done
ok


After manually installing Build-Depends packages, except for the three unmet
dependencies reported by builddeps above, and additionally installing python-
sphinx and python-sphinx-rtd-theme (Build-Depends-Indep mentions the python3
versions of those sphinx packages), then, the command debuild -d -b -uc -us
succeeded.

So, removing python-olefile, python3-olefile, and libraqm-dev from Build-
Depends may suffice.

Best
Ale



-- System Information:
Debian Release: 9.3
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.9.0-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_IE.UTF-8, LC_CTYPE=en_IE.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_IE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: sysvinit (via /sbin/init)

--- End Message ---
--- Begin Message ---
closing this issue. There is no guarantee that an unmodified package can be
backported. And not that interested in tracking backport issues here in the 
tracker.

--- End Message ---

Reply via email to