Your message dated Wed, 04 Apr 2018 21:00:15 +0000
with message-id <e1f3pvv-00019j...@fasolo.debian.org>
and subject line Bug#777081: fixed in kopete 4:18.03.80-1
has caused the Debian Bug report #777081,
regarding kopete: Browser plugin should be removed or in a separate package
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
777081: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=777081
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: kopete
Version: 4:4.14.1-2
Severity: normal

I just noticed that kopete installs a mozilla browser plugin. There
seems to be little information on what this plugin does. In particular,
the kopete package description does not give any hint about this.

Since this greatly increases the attack surface for security issues in
mozilla, the plugin should be moved to a separate package and there
should be some indication what the plugin does.

-- System Information:
Debian Release: 8.0
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages kopete depends on:
ii  kde-runtime             4:4.14.2-2
ii  kdepim-runtime          4:4.14.2-3
ii  libc6                   2.19-14
ii  libexpat1               2.1.0-6+b3
ii  libgadu3                1:1.12.0-5
ii  libgif4                 4.1.6-11
ii  libglib2.0-0            2.42.1-1
ii  libidn11                1.29-1+b2
ii  libjasper1              1.900.1-debian1-2.4
ii  libkabc4                4:4.14.2-2+b1
ii  libkcmutils4            4:4.14.2-5
ii  libkde3support4         4:4.14.2-5
ii  libkdecore5             4:4.14.2-5
ii  libkdeui5               4:4.14.2-5
ii  libkdnssd4              4:4.14.2-5
ii  libkemoticons4          4:4.14.2-5
ii  libkhtml5               4:4.14.2-5
ii  libkio5                 4:4.14.2-5
ii  libkmime4               4:4.14.2-2+b1
ii  libknewstuff2-4         4:4.14.2-5
ii  libknotifyconfig4       4:4.14.2-5
ii  libkopete4              4:4.14.1-2
ii  libkparts4              4:4.14.2-5
ii  libkpimidentities4      4:4.14.2-2+b1
ii  libmeanwhile1           1.0.2-5
ii  libmediastreamer-base3  3.6.1-2.4+b1
ii  libmsn0.3               4.2-2
ii  libortp9                3.6.1-2.4+b1
ii  libotr5                 4.1.0-2
ii  libphonon4              4:4.8.0-4
ii  libqca2                 2.0.3-6
ii  libqimageblitz4         1:0.0.6-4
ii  libqt4-dbus             4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqt4-network          4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqt4-qt3support       4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqt4-sql              4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqt4-xml              4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqtcore4              4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libqtgui4               4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
ii  libsolid4               4:4.14.2-5
ii  libsrtp0                1.4.5~20130609~dfsg-1.1
ii  libssl1.0.0             1.0.1k-1
ii  libstdc++6              4.9.2-10
ii  libv4l-0                1.6.0-2
ii  libx11-6                2:1.6.2-3
ii  libxml2                 2.9.2+dfsg1-3
ii  libxslt1.1              1.1.28-2+b2
ii  perl                    5.20.1-5
ii  phonon                  4:4.8.0-4
ii  zlib1g                  1:1.2.8.dfsg-2+b1

Versions of packages kopete recommends:
ii  libqca2-plugin-ossl  2.0.0~beta3-2
ii  libqt4-sql-sqlite    4:4.8.6+git64-g5dc8b2b+dfsg-2+b1

Versions of packages kopete suggests:
ii  imagemagick           8:6.8.9.9-5
pn  kdeartwork-emoticons  <none>
ii  khelpcenter4          4:4.14.2-2
ii  texlive-latex-base    2014.20141024-2

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: kopete
Source-Version: 4:18.03.80-1

We believe that the bug you reported is fixed in the latest version of
kopete, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 777...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Pino Toscano <p...@debian.org> (supplier of updated kopete package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Mon, 02 Apr 2018 23:00:17 +0200
Source: kopete
Binary: libkopete1 kopete kopete-data libkopete-dev
Architecture: source all amd64
Version: 4:18.03.80-1
Distribution: experimental
Urgency: medium
Maintainer: Debian/Kubuntu Qt/KDE Maintainers <debian-qt-...@lists.debian.org>
Changed-By: Pino Toscano <p...@debian.org>
Description:
 kopete     - instant messaging and chat application
 kopete-data - data files for Kopete
 libkopete-dev - development files for the Kopete instant messaging and chat 
appli
 libkopete1 - main Kopete library
Closes: 777081 874985
Changes:
 kopete (4:18.03.80-1) experimental; urgency=medium
 .
   * Team upload.
   * New upstream development release:
     - no more ships a browser plugin (Closes: #777081)
     - switches to Qt5/KF5 (Closes: #874985)
   * Update the build dependencies following the port to Frameworks:
     - remove kde-sc-dev-latest, kdelibs5-dev, kdepimlibs5-dev, libqca2-dev,
       libqimageblitz-dev, and libqjson-dev
     - add extra-cmake-modules, qtbase5-dev, libkf5config-dev,
       libkf5contacts-dev, libkf5coreaddons-dev, libkf5crash-dev,
       libkf5dbusaddons-dev, libkf5doctools-dev, libkf5emoticons-dev,
       libkf5i18n-dev, libkf5identitymanagement-dev, libkf5kcmutils-dev,
       libkf5kdelibs4support-dev, libkf5khtml-dev, libkf5kio-dev,
       libkf5libkleo-dev, libkf5notifyconfig-dev, libkf5parts-dev,
       libkf5texteditor-dev, libkf5wallet-dev, libphonon4qt5-dev,
       libphonon4qt5experimental-dev, and libqca-qt5-2-dev
   * Switch the libgpgme11-dev build dependency to libgpgmepp-dev.
   * Use the right makefile class:
     - use debian-qt-kde.mk v3
     - bump the pkg-kde-tools build dependency to >= 0.15.16
   * Use https for Format in copyright.
   * Rename libkopete4 to libkopete1, following the upstream SONAME change.
   * Update/rewrite install files.
   * Update symbols file.
   * Break/replace against kde-l10n that ships translations.
   * Switch to dh-exec for installing libjingle-call only on Linux
     architectures:
     - add the dh-exec build dependency
     - ensure usr/bin/libjingle-call is installed only on linux-any
       architectures
     - remove creation/removal of kopete.install.kfreebsd
   * Update the runtime relationships:
     - replace libqca2-plugins with libqca-qt5-2-plugins
     - replace libqt4-sql-sqlite with libqt5sql5-sqlite
     - remove texlive-latex-base, as there is no LaTeX plugin
     - remove kdeartwork-emoticons, as it does not exist anymore
     - switch from the result of dh_sameversiondep to a simple qtbase5-dev for
       libkopete-dev: it should be enough for now
   * Update lintian overrides.
   * Stop excluding kdepim-runtime from the dh_shlibdeps results, as it is no
     more injected.
   * Split a kopete-data out of kopete
     - add proper breaks/replaces
   * Update watch file to point to the unstable releases, for now.
   * Drop the dh_acc autopkgtest, and stuff, since it is long outdated.
   * Enable the test suite:
     - add the xauth, and xvfb build dependencies
     - run dh_auto_test under xvfb-run
     - drop the autopkgtest running it (since it is also the wrong place for it)
   * Update README.Debian to the various changes.
Checksums-Sha1:
 8ef5742d8867a4b065286c443b49253b5b1c60a5 3444 kopete_18.03.80-1.dsc
 3f9a7f1247c28c7c9f48d0fadff00343117fd7be 9749684 kopete_18.03.80.orig.tar.xz
 5213e8ffee25aeb7ac01dbd09811c746d16e6734 57464 kopete_18.03.80-1.debian.tar.xz
 a6466275da801447045c2623c2d3843b1e096ce9 6543448 kopete-data_18.03.80-1_all.deb
 c6d04857e8087ca3ca5c24a80cb0d3082b58c783 87682268 
kopete-dbgsym_18.03.80-1_amd64.deb
 1eea9e2078291c7715713f0a27c8956afe97cc5e 27094 
kopete_18.03.80-1_amd64.buildinfo
 5fa9109e34754d0d398e48a802a3e0c341f20792 3173416 kopete_18.03.80-1_amd64.deb
 0595b76d3a19441dbffa7988f8e83af341cf0800 124344 
libkopete-dev_18.03.80-1_amd64.deb
 c47d5786a6a5be354a80845989a4cf1e797fcd8c 10210420 
libkopete1-dbgsym_18.03.80-1_amd64.deb
 c9bef9dc33949048d7c2b60a3f83ceced5a02421 434156 libkopete1_18.03.80-1_amd64.deb
Checksums-Sha256:
 6b1c6d8bb35a76e03f7e6a4469acbdbc320fb8d23c0df1e736694821fcee41ed 3444 
kopete_18.03.80-1.dsc
 6326a2ea7486c0f746e9ff59cac2a5f3e404fc6f381dcca03222a6f57bdf23a4 9749684 
kopete_18.03.80.orig.tar.xz
 c5fe0b1b4a606f0d8f8143bf812e8812ec84f9098e05ca29a951ab7cfd6112af 57464 
kopete_18.03.80-1.debian.tar.xz
 80e99a70d115b056f2d423e786610dd52037c68fcc29b3c927838d22c0565f5d 6543448 
kopete-data_18.03.80-1_all.deb
 2891190ccee0bab04b8bc624dcb0552793d3e08b5ac350a984caa0dc1167f006 87682268 
kopete-dbgsym_18.03.80-1_amd64.deb
 059d2294088fd9c7cff2d364748646c1a8c8996d754a368ec69f1d80ac35d4a6 27094 
kopete_18.03.80-1_amd64.buildinfo
 2b05cdf9cdb229181d32e00438f77f86bb8186b2746ecf0b3ae7e1dfd2546cd2 3173416 
kopete_18.03.80-1_amd64.deb
 726b562005bc9cdf83e5c59507327cb6d373ec7e29ae420b587bb7b4d7097562 124344 
libkopete-dev_18.03.80-1_amd64.deb
 b4d348e48e5d6145a07f6c7b5d99db0b6f3950583183f7af16dd21cce88f8302 10210420 
libkopete1-dbgsym_18.03.80-1_amd64.deb
 b0d04fd9aa58c2920c72006f9c0f08ad649d70755b74ab01d0a9c372ad75bd02 434156 
libkopete1_18.03.80-1_amd64.deb
Files:
 b5f631c82b461c3963425298790adb6a 3444 kde optional kopete_18.03.80-1.dsc
 197b5b656b6abcb487a4b4fe3fbd68b9 9749684 kde optional 
kopete_18.03.80.orig.tar.xz
 73fa031786e2c8660f8b68cf430b4897 57464 kde optional 
kopete_18.03.80-1.debian.tar.xz
 f941fa17207c8f8eba440711c73e7ca4 6543448 net optional 
kopete-data_18.03.80-1_all.deb
 f9a0cc3e4b121a55e9b62676cac21611 87682268 debug optional 
kopete-dbgsym_18.03.80-1_amd64.deb
 6da5e71a29bce7fc48d08565333ac4d7 27094 kde optional 
kopete_18.03.80-1_amd64.buildinfo
 158ea09c6816f6f58dd0b83c099af511 3173416 net optional 
kopete_18.03.80-1_amd64.deb
 3d774199e07ab21addc36f50c64e49ba 124344 libdevel optional 
libkopete-dev_18.03.80-1_amd64.deb
 de0d07ce23186da179ab09fed05d1670 10210420 debug optional 
libkopete1-dbgsym_18.03.80-1_amd64.deb
 00e55bba9b19cd3cbf90ec3314de729c 434156 libs optional 
libkopete1_18.03.80-1_amd64.deb

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEXyqfuC+mweEHcAcHLRkciEOxP00FAlrCnzIACgkQLRkciEOx
P0040g/9Hwb7dnXKPon7lCnRh/j8ryXs2yUKYi/xFQCXFwimXGFhVGlx0F7nselB
Wt986xdlM99oWCa6ic7oSG6p07y9p16cdGbictFckZpMhUx0qT5wwYeOmQHOQibm
170AGRdDMsP9NSDCH3H46I+u17WZnkLBtkHDNeRFeVz85SGXmzPwXNL6r/ZF6KIr
XjjfS5kLBpB2YB3iii3VW10J/2zryekkVGA2zaXsR5cHQSnsD4BnW1YvsoH3qo6/
Xz6dicGK1L2XIxoVk9pUTZfRKmrDLuXBWoC2Gnwy6p2glpID/mjlzpjxyqbd8ngw
eNskyrQtM3kLiWnDWA9II4BLxHrTkSuagTgOA0dg9VfVeh2q24u+TBe3NgYacEAn
GIN5KGAjYTF6z0gKqOk7+33dREtkW7n9n9fRb+W7AbU2kN/5qxI/egRoTH5iIPDv
rz/OrZDou7okeK8jDY9yksubtBThxBjtAvBY0EHzeFPkWZJwKOGHAD/TsMZT+HQL
1mRz78m5+hKQyZITQ7KgUJmF6MRRkNKLzbCAL7B85qNbJr58ewf0Ejw0jMQW8NKG
N4pXYzRDdRqNwGLJpMEgBIayJIt1UiAxV6RVi8TRm88WIJvRLML2SCe6Rz6XAwhn
eAowIJx0QtxkYogDSFBCUIjMD+zPnNAzao+Oz9rHoBhUb5rhSYY=
=l9JV
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to