Your message dated Fri, 06 Apr 2018 15:12:13 +0200
with message-id <>
and subject line Re: [Pkg-xfce-devel] Bug#648338: Bug#648338: Bug#648338: 
thunar: Problems occur after update to gtk3(?): no file or menu icons, no file 
has caused the Debian Bug report #648338,
regarding thunar: Problems occur after update to gtk3(?): no file or menu 
icons, no file associations
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: thunar
Version: 1.2.3-2
Severity: important

Dear Maintainer,

yesterday I ran a system update (using synaptic) which included gtk3 and
related libs. After the next login Thunar behaved very weirdly:

* The icons in Thunar are missing, as well for the files as for the menus.
* All file type associations seemed to be gone.

I checked with a newly created profile and logged in using XFCE. There, it
seemed to work.

I checked with my own user, using an empty .config folder. This seemed to work
at first. But after playing around a bit (I think I changed some settings,
too), logging out and in again, the problem was there again. I tried with
several sets of folders from the original .config and the newly created one.
The problem always remained. I get the impression that some file(s) outside of
..config may be responsible.

Today, after logging out and back in several times (for other reasons), I
clicked on a toolbar starter for Thunar (command in the starter's settings is
simply "thunar") right after logging in. This time the icons and file type
associations were there. But alas, when opening the home folder (clicking it's
icon on the desktop) the new Thunar window had no icons, nor file type
associations. When starting another instance using the already mentioned
starter in the toolbar, this instance was also lacking icons and associations.

I do not know if my problems have to do with the fact that I updated with
synaptic and XFCE + Thunar were running at the time of the update. But if so,
this problem should be avoided by either providing a clean update path (i.e.
conversions where necessary) or a warning to the user that this upgrade should
be run while no X(FCE?) or no Thunar instance is running.

What can I do to find out where the problem originates and how to solve it?

Kind regards


-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 3.0.0-1-686-pae (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages thunar depends on:
ii  desktop-file-utils  0.15-2    
ii  exo-utils           0.6.2-3   
ii  libatk1.0-0         2.2.0-2   
ii  libc6               2.13-21   
ii  libcairo2           1.10.2-6.1
ii  libdbus-1-3         1.4.16-1  
ii  libdbus-glib-1-2    0.98-1    
ii  libexo-1-0          0.6.2-3   
ii  libgdk-pixbuf2.0-0  2.24.0-1  
ii  libglib2.0-0        2.28.8-1  
ii  libgtk2.0-0         2.24.7-1  
ii  libgudev-1.0-0      172-1     
ii  libice6             2:1.0.7-2 
ii  libnotify4          0.7.4-1   
ii  libpango1.0-0       1.29.4-2  
ii  libsm6              2:1.2.0-2 
ii  libthunarx-2-0      1.2.3-2   
ii  libxfce4ui-1-0      4.8.0-3   
ii  libxfce4util4       4.8.2-1   
ii  shared-mime-info    0.90-1    
ii  thunar-data         1.2.3-2   

Versions of packages thunar recommends:
ii  dbus-x11        1.4.16-1  
ii  gvfs            1.8.2-2   
ii  libfontconfig1  2.8.0-3   
ii  libfreetype6    2.4.7-2   
ii  thunar-volman   0.6.0-4+b1
ii  tumbler         0.1.22-1  
ii  xdg-user-dirs   0.14-1    
ii  xfce4-panel     4.8.6-1   

Versions of packages thunar suggests:
ii  thunar-archive-plugin     0.3.0-4
ii  thunar-media-tags-plugin  0.1.2-3

-- no debconf information

--- End Message ---
--- Begin Message ---
On Sun, 2013-06-16 at 16:13 +0200, Yves-Alexis Perez wrote:
> Sorry for the delay but, in the end, what's the situation. Does this bug
> still exist?

Without news since 2013, I guess we can safely close that bug.

Attachment: signature.asc
Description: This is a digitally signed message part

--- End Message ---

Reply via email to