Your message dated Tue, 10 Apr 2018 07:58:05 +0000
with message-id <e1f5oah-00020a...@fasolo.debian.org>
and subject line Bug#871679: fixed in libcacard 1:2.5.3-1
has caused the Debian Bug report #871679,
regarding libcacard FTCBFS: libtool-bin build dependency unsatisfiable
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
871679: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=871679
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: libcacard
Version: 1:2.5.0-3
Tags: patch
User: helm...@debian.org
Usertags: rebootstrap

libcacard fails to cross build from source, because its Build-Depends:
libtool-bin is unsatisfiable. It turns out that libcacard doesn't need
libtool-bin and only needs libtool. After demoting the dependency, a
build generates the very same build-ids as before. Also a cross build
succeeds. libtool-bin is supposed to be removed from the archive
eventually. Please consider applying the attached patch.

Helmut
diff --minimal -Nru libcacard-2.5.0/debian/changelog 
libcacard-2.5.0/debian/changelog
--- libcacard-2.5.0/debian/changelog    2017-03-04 09:57:45.000000000 +0100
+++ libcacard-2.5.0/debian/changelog    2017-08-10 18:14:03.000000000 +0200
@@ -1,3 +1,10 @@
+libcacard (1:2.5.0-3.1) UNRELEASED; urgency=medium
+
+  * Non-maintainer upload.
+  * Fix FTCBFS: demote libtool-bin build dependency to libtool (Closes: #-1)
+
+ -- Helmut Grohne <hel...@subdivi.de>  Thu, 10 Aug 2017 18:14:03 +0200
+
 libcacard (1:2.5.0-3) unstable; urgency=high
 
   * smartcard-fix-memory-leak-in-vcard_apdu_new-CVE-2017-6414.patch
diff --minimal -Nru libcacard-2.5.0/debian/control 
libcacard-2.5.0/debian/control
--- libcacard-2.5.0/debian/control      2017-03-03 06:58:37.000000000 +0100
+++ libcacard-2.5.0/debian/control      2017-08-10 18:14:03.000000000 +0200
@@ -2,7 +2,7 @@
 Section: otherosfs
 Priority: extra
 Maintainer: Michael Tokarev <m...@tls.msk.ru>
-Build-Depends: debhelper (>=9), pkg-config, libtool-bin,
+Build-Depends: debhelper (>=9), pkg-config, libtool,
  libnss3-dev (>=3.12.8~),
  libglib2.0-dev (>=2.22~),
 Standards-Version: 3.9.6

--- End Message ---
--- Begin Message ---
Source: libcacard
Source-Version: 1:2.5.3-1

We believe that the bug you reported is fixed in the latest version of
libcacard, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 871...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Michael Tokarev <m...@tls.msk.ru> (supplier of updated libcacard package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Tue, 10 Apr 2018 09:03:52 +0300
Source: libcacard
Binary: libcacard0 libcacard-dev libcacard-tools
Architecture: source
Version: 1:2.5.3-1
Distribution: unstable
Urgency: medium
Maintainer: Michael Tokarev <m...@tls.msk.ru>
Changed-By: Michael Tokarev <m...@tls.msk.ru>
Description:
 libcacard-dev - Virtual Common Access Card (CAC) Emulator (development files)
 libcacard-tools - Virtual Common Access Card (CAC) Emulator (tools)
 libcacard0 - Virtual Common Access Card (CAC) Emulator (runtime library)
Closes: 822720 871679
Changes:
 libcacard (1:2.5.3-1) unstable; urgency=medium
 .
   [ Laurent Bigonville ]
   * New upstream release (Closes: #822720)
     - Drop patches applied upstream and refresh the remaining one
     - debian/libcacard0.symbols: Add new exported symbol
   * debian/control:
     - Bump Standards-Version to 4.1.3 (no further changes)
     - Bump priority to optional, extra is deprecated
     - Add libpcsclite-dev to the build-dependency to enabled pcsc passthrough
 .
   [ Helmut Grohne ]
   * Fix FTCBFS: demote libtool-bin build dependency to libtool (Closes: 
#871679)
Checksums-Sha1:
 2cb656f288595992c9475e2f46f3cd06e32af4ee 1750 libcacard_2.5.3-1.dsc
 b085bdf0b7558088c490f733aa1e1f6ab5b81787 325616 libcacard_2.5.3.orig.tar.xz
 0809784cb35cb2c6914640685192d6c6069db358 3948 libcacard_2.5.3-1.debian.tar.xz
 6e6c53ea42a13fc7707f199aa7cdc5eafc15c17e 6078 
libcacard_2.5.3-1_source.buildinfo
Checksums-Sha256:
 29229a234e42a7cb5a89858b3874b7f4c42b844d1144bb74e5adf0c3f2069362 1750 
libcacard_2.5.3-1.dsc
 243ff03c563a95faed497db7f524fcb34ccd6f388d1175ecf31c371a3188963b 325616 
libcacard_2.5.3.orig.tar.xz
 e89ae626e49aa13a0666d4148962eaa5eba2d0f401f8424c59225d8751f53fb4 3948 
libcacard_2.5.3-1.debian.tar.xz
 1eea7fe3fdd4e65f1ba36b406c74759014f5319030725d3bbcf612b75b154522 6078 
libcacard_2.5.3-1_source.buildinfo
Files:
 93637d1191d5df2d040a5eb3de4a0200 1750 otherosfs optional libcacard_2.5.3-1.dsc
 362a021853699008e00aaa1fecdc26c0 325616 otherosfs optional 
libcacard_2.5.3.orig.tar.xz
 fbf4eb3262efb3a1744672d02e402d32 3948 otherosfs optional 
libcacard_2.5.3-1.debian.tar.xz
 8eae6679254336485bb18e9f14755c8c 6078 otherosfs optional 
libcacard_2.5.3-1_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQFDBAEBCAAtFiEEe3O61ovnosKJMUsicBtPaxppPlkFAlrMWVwPHG1qdEB0bHMu
bXNrLnJ1AAoJEHAbT2saaT5ZwKgIALiHZLTb3tu+cUQ94dX76fszJVl8b/jeKp4l
IuSgJhH6i66y44CFqp9zfyZKAn9xZnwKLJQQr7lRL9Oxj6g8senlAt7wqrMzNw1e
xkxwLaBK/9BSgeqGN8Rx5JDEPaEark+MUjuCnxBEXGWm3LtTilZFCy6xERc1VqLZ
uspm51mKGviwVDzNaCii2QRl0eH2+M+IPDwqGbTi3bbODjkjEobuy2TEopmxlNeL
SL1ASWMGKP2L8iHIhiQNz37okJnT6I2tAqdUJKDqPjWybne+7RPtz274yd3WPeQA
hA9a90TrIH54bEmXb7v+mMwOZxxlHA6tTGGAOsD8krjbOLTjEeI=
=b1vD
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to