Your message dated Wed, 11 Apr 2018 23:56:51 +0000
with message-id <e1f6pbf-000aut...@fasolo.debian.org>
and subject line Bug#851268: fixed in sopel 6.5.3-1
has caused the Debian Bug report #851268,
regarding sopel: first sopel start fails because of missing configration
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
851268: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=851268
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: sopel
Version: 6.5.0-1
Severity: important

Dear Maintainer,

Thank you for creating the sopel package for Debian.


   * What led up to the situation?

I installed the package and tried to configure it by using the commands
which were in the README.Debian file.

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

I ran the following commands as root:
chown sopel /etc/sopel.cfg
sudo -u sopel sopel --config /etc/sopel.cfg --configure-all

   * What was the outcome of this action?

Creating a config directory at ~/.sopel...
Please answer the following questions to create your configuration file:

Encountered an error while writing the config file. This shouldn't happen. 
Check permissions.
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/sopel/config/types.py", line 338, in 
parse
    os.makedirs(value)
  File "/usr/lib/python3.5/os.py", line 241, in makedirs
    mkdir(name, mode)
PermissionError: [Errno 13] Permission denied: '/etc/logs'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/sopel/config/types.py", line 59, in 
__init__
    getattr(self, value)
  File "/usr/lib/python3/dist-packages/sopel/config/types.py", line 306, in 
__get__
    return self.parse(main_config, this_section, value)
  File "/usr/lib/python3/dist-packages/sopel/config/types.py", line 341, in 
parse
    "Value must be an existing or creatable directory.")
ValueError: Value must be an existing or creatable directory.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/sopel", line 11, in <module>
    load_entry_point('sopel==6.5.0', 'console_scripts', 'sopel')()
  File "/usr/lib/python3/dist-packages/sopel/run_script.py", line 111, in main
    _wizard('all', opts.config)
  File "/usr/lib/python3/dist-packages/sopel/config/__init__.py", line 217, in 
_wizard
    _create_config(configpath)
  File "/usr/lib/python3/dist-packages/sopel/config/__init__.py", line 250, in 
_create_config
    config = Config(configpath, validate=False)
  File "/usr/lib/python3/dist-packages/sopel/config/__init__.py", line 64, in 
__init__
    validate=validate)
  File "/usr/lib/python3/dist-packages/sopel/config/__init__.py", line 118, in 
define_section
    setattr(self, name, cls_(self, name, validate=validate))
  File "/usr/lib/python3/dist-packages/sopel/config/types.py", line 63, in 
__init__
    str(e))
ValueError: Invalid value for core.logdir: Value must be an existing or 
creatable directory.

   * What outcome did you expect instead?

The possibility to configure sopel.

To be able to configure sopel, the command should be:
sudo -u sopel sopel --config /etc/sopel --configure-all

Notice there is no .cfg at the end of the config file.

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.8.0-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages sopel depends on:
ii  adduser              3.115
ii  init-system-helpers  1.46
ii  lsb-base             9.20161125
ii  python3-enchant      1.6.7-1
ii  python3-requests     2.12.4-1
ii  python3-tz           2016.7-0.2
pn  python3:any          <none>

Versions of packages sopel recommends:
ii  ipython3            5.1.0-3
ii  python3-feedparser  5.1.3-3
ii  python3-lxml        3.6.4-1
ii  python3-praw        3.3.0-1
ii  python3-xmltodict   0.10.2-1

sopel suggests no packages.

-- Configuration Files:
/etc/sopel.cfg changed [not included]

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: sopel
Source-Version: 6.5.3-1

We believe that the bug you reported is fixed in the latest version of
sopel, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 851...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Antoine Beaupré <anar...@debian.org> (supplier of updated sopel package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Wed, 11 Apr 2018 18:51:57 -0400
Source: sopel
Binary: sopel
Architecture: source all
Version: 6.5.3-1
Distribution: unstable
Urgency: medium
Maintainer: Antoine Beaupré <anar...@debian.org>
Changed-By: Antoine Beaupré <anar...@debian.org>
Description:
 sopel      - simple, lightweight, open source, easy-to-use IRC utility bot
Closes: 851268
Changes:
 sopel (6.5.3-1) unstable; urgency=medium
 .
   * new upstream release
   * fix error in configuration sample (Closes: #851268)
   * remove patch about missing dependencies in jessie, we are beyond
     oldstable backports now
   * add patch to remove ipython support, which will soon be removed
     upstream, as it breaks trivial backporting to stretch
Checksums-Sha1:
 9edcaa087d0ce2fa8fecdf24112b51ad28faab63 1523 sopel_6.5.3-1.dsc
 263e8052bee286c2c8152f374a2b0b8eae671723 139286 sopel_6.5.3.orig.tar.gz
 bae54ea18bf5845bf80c5cffc8bf44ad8d5d438d 7332 sopel_6.5.3-1.debian.tar.xz
 cb6395ffc0e83e1e6e77d0f61c022edc409fa529 110960 sopel_6.5.3-1_all.deb
 9c6088b6bebfdaf239f78e30708c418126da3e66 5775 sopel_6.5.3-1_amd64.buildinfo
Checksums-Sha256:
 10ae6dce369e2a7a71515d8e7b098fb04ef78d9d6043c4bd084612a2d320547e 1523 
sopel_6.5.3-1.dsc
 95e8da04e50d43f661508e8cc6e9bbf57eea8f947e30e2b1612dd7989b80a4f2 139286 
sopel_6.5.3.orig.tar.gz
 2f8199abf36a0b7391bbd828ee99180e131ff5a284ebfe03e5fe2a771bcf12db 7332 
sopel_6.5.3-1.debian.tar.xz
 430d88e813ba27ec139d7d69d4d8b2d66bc4d66572cf0cfcc9e001528721b1b7 110960 
sopel_6.5.3-1_all.deb
 b009409f5e99d1c59317d9651557727b26d97f225237728fce36a80fcf2e2e8b 5775 
sopel_6.5.3-1_amd64.buildinfo
Files:
 1398466b663acd2b49099444d2735646 1523 net optional sopel_6.5.3-1.dsc
 cc188a649aecd57443b44ee3c7e39f39 139286 net optional sopel_6.5.3.orig.tar.gz
 51d264faf36c26c01c364e6f877dd93a 7332 net optional sopel_6.5.3-1.debian.tar.xz
 8ae02c7b36203cf720932550a6bee494 110960 net optional sopel_6.5.3-1_all.deb
 b5b0f0d882f5e52da2bfb579dc67c4f4 5775 net optional 
sopel_6.5.3-1_amd64.buildinfo

-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEexZCBNCWcjsBljWrPqHd3bJh2XsFAlrOltUACgkQPqHd3bJh
2XskLwgAmBF9KIBuSBPMjSecS4E5l9QqI3SO6EtjXQlAtAhWoQusq/3xS/pI3p8i
Jstb1+8ythkzn1l1V5cKHv2LpzR4EqLyoFUU2pL0wlg7OLmKvsCejYSkmMsPDDwP
g1+n8FVCbLOX1TlKwXrqTHQybKt9v0g5xxQYkjpsr1XHGfv2EmP1e4pVTT3G4/q5
/vEvNVzElihHY1l3Fxm506/Q/F1g/nBsBw7EzBtevJT1ChOF0SXavgAs6PhQLl7l
L+FvcQO40VLfn2Od7TG4comtxvZ9UVJH8zZOgwbi8HlhmJpPtsamytug80lKFzfb
6GFkF6cvAp+4cBXK4ClHmWbMAsGoRg==
=l7fi
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to