Your message dated Thu, 12 Apr 2018 12:07:16 +0000
with message-id <e1f6b0w-000cv3...@fasolo.debian.org>
and subject line Bug#895386: fixed in qt3d-opensource-src 5.10.1+dfsg-4
has caused the Debian Bug report #895386,
regarding qt3d5-dev: Package doesn't include dir 
/usr/include/x86_64-linux-gnu/qt5/Qt3DExtras
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
895386: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895386
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: qt3d5-dev
Version: 5.10.1+dfsg-3
Severity: important

Dear Maintainer,

When trying to build QGis 3.0 from source, at some point CMake reports
the following error:

        CMake Error at 
/usr/lib/x86_64-linux-gnu/cmake/Qt53DExtras/Qt53DExtrasConfig.cmake:27 
(message):
          The imported target "Qt5::3DExtras" references the file

             "/usr/include/x86_64-linux-gnu/qt5/Qt3DExtras"

          but this file does not exist.  Possible reasons include:

          * The file was deleted, renamed, or moved to another location.

          * An install or uninstall procedure did not complete successfully.

          * The installation package was faulty and contained

             
"/usr/lib/x86_64-linux-gnu/cmake/Qt53DExtras/Qt53DExtrasConfig.cmake"

          but not all the files it references.

The directory and its contents is included in the upstream source tarball, but 
for some reason didn't make to the Debian package.

In fact, the source tarball has 13 directories under include:

~/software/qt3d-everywhere-src-5.10.1/include]$ ls -ld
Qt3DAnimation
Qt3DCore
Qt3DCoreTest
Qt3DExtras
Qt3DInput
Qt3DLogic
Qt3DQuick
Qt3DQuickAnimation
Qt3DQuickExtras
Qt3DQuickInput
Qt3DQuickRender
Qt3DQuickScene2D
Qt3DRender

whereas qt3d5-dev only has the following 8:

$ ls -d /usr/include/x86_64-linux-gnu/qt5/Qt3D*
/usr/include/x86_64-linux-gnu/qt5/Qt3DCore
/usr/include/x86_64-linux-gnu/qt5/Qt3DExtras
/usr/include/x86_64-linux-gnu/qt5/Qt3DInput
/usr/include/x86_64-linux-gnu/qt5/Qt3DLogic
/usr/include/x86_64-linux-gnu/qt5/Qt3DQuick
/usr/include/x86_64-linux-gnu/qt5/Qt3DQuickInput
/usr/include/x86_64-linux-gnu/qt5/Qt3DQuickRender
/usr/include/x86_64-linux-gnu/qt5/Qt3DQuickScene2D
/usr/include/x86_64-linux-gnu/qt5/Qt3DRender

Manually copying Qt3DExtras from the source tarball to the system include dir 
solves the problem for me; I believe the package should include all those files 
from the source tarball. Thanks.

-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.16.0minerva (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages qt3d5-dev depends on:
ii  libqt53danimation5       5.10.1+dfsg-3
ii  libqt53dcore5            5.10.1+dfsg-3
ii  libqt53dextras5          5.10.1+dfsg-3
ii  libqt53dinput5           5.10.1+dfsg-3
ii  libqt53dlogic5           5.10.1+dfsg-3
ii  libqt53dquick5           5.10.1+dfsg-3
ii  libqt53dquickanimation5  5.10.1+dfsg-3
ii  libqt53dquickextras5     5.10.1+dfsg-3
ii  libqt53dquickinput5      5.10.1+dfsg-3
ii  libqt53dquickrender5     5.10.1+dfsg-3
ii  libqt53dquickscene2d5    5.10.1+dfsg-3
ii  libqt53drender5          5.10.1+dfsg-3
ii  qtbase5-dev              5.10.1+dfsg-5

qt3d5-dev recommends no packages.

Versions of packages qt3d5-dev suggests:
ii  qt3d5-doc       5.10.1+dfsg-3
pn  qt3d5-doc-html  <none>

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: qt3d-opensource-src
Source-Version: 5.10.1+dfsg-4

We believe that the bug you reported is fixed in the latest version of
qt3d-opensource-src, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 895...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Lisandro Damián Nicanor Pérez Meyer <lisan...@debian.org> (supplier of updated 
qt3d-opensource-src package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Thu, 12 Apr 2018 08:53:34 -0300
Source: qt3d-opensource-src
Binary: libqt53dcore5 libqt53dquick5 libqt53dquickrender5 libqt53dinput5 
libqt53drender5 libqt53dlogic5 libqt53dquickinput5 libqt53dquickextras5 
libqt53dextras5 libqt53dquickscene2d5 libqt53danimation5 
libqt53dquickanimation5 qt3d5-dev-tools qt3d-gltfsceneio-plugin 
qt3d-assimpsceneimport-plugin qt3d-defaultgeometryloader-plugin 
qt3d-scene2d-plugin qml-module-qt3d qml-module-qtquick-scene3d 
qml-module-qtquick-scene2d qt3d5-dev qt3d5-examples qt3d5-doc qt3d5-doc-html
Architecture: source
Version: 5.10.1+dfsg-4
Distribution: unstable
Urgency: medium
Maintainer: Debian Qt/KDE Maintainers <debian-qt-...@lists.debian.org>
Changed-By: Lisandro Damián Nicanor Pérez Meyer <lisan...@debian.org>
Description:
 libqt53danimation5 - Qt 3D animation module
 libqt53dcore5 - Qt 3D module
 libqt53dextras5 - Qt 3D extras
 libqt53dinput5 - Qt 3D Input module
 libqt53dlogic5 - Qt 3D logic module
 libqt53dquick5 - Qt 3D Quick module
 libqt53dquickanimation5 - Qt 3D Quick animation module
 libqt53dquickextras5 - Qt 3D Quick extras
 libqt53dquickinput5 - Qt 3D Quick input
 libqt53dquickrender5 - Qt 3D Quick Renderer module
 libqt53dquickscene2d5 - Qt 3D Quick scene module
 libqt53drender5 - Qt 3D Renderer module
 qml-module-qt3d - Qt 5 3D QML module
 qml-module-qtquick-scene2d - Qt 5 Quick Scene 2D QML module
 qml-module-qtquick-scene3d - Qt 5 Quick Scene 3D QML module
 qt3d-assimpsceneimport-plugin - Qt 3D GL Assimp scene import plugin
 qt3d-defaultgeometryloader-plugin - Qt 3D default geometry loader plugin
 qt3d-gltfsceneio-plugin - Qt 3D GL Transmission Format scene IO plugin
 qt3d-scene2d-plugin - Qt 3D Scene 2D plugin
 qt3d5-dev  - Qt 5 3D development files
 qt3d5-dev-tools - Qt 3D development tools
 qt3d5-doc  - Qt 3D documentation
 qt3d5-doc-html - Qt 3D HTML documentation
 qt3d5-examples - Qt 5 3d examples
Closes: 895386 895507
Changes:
 qt3d-opensource-src (5.10.1+dfsg-4) unstable; urgency=medium
 .
   * Do not ship CMake files for Qt53DQuickExtras and Qt53DExtras
     (Closes: #895386, #895507).
Checksums-Sha1:
 fa2f36f41c777ac46625614ef62619be2b884e5c 4306 
qt3d-opensource-src_5.10.1+dfsg-4.dsc
 34e8a6260314111a1615938cb56f28e210646eef 56740 
qt3d-opensource-src_5.10.1+dfsg-4.debian.tar.xz
 d83a4d58fddbfbebf04807b5c402442bb3d625e6 12178 
qt3d-opensource-src_5.10.1+dfsg-4_source.buildinfo
Checksums-Sha256:
 e99bd0518e6fbc64f3d77c3075ec0c8f6c12265996f68f24eac6575242ed88db 4306 
qt3d-opensource-src_5.10.1+dfsg-4.dsc
 74d0843d8c92b4529cf18debc790eaee62fa46439a8fe3772489bdf3f0b29b6d 56740 
qt3d-opensource-src_5.10.1+dfsg-4.debian.tar.xz
 1c6731832cb003c4a38ff44c478925631665d963b2af6b6d32cfde14201af335 12178 
qt3d-opensource-src_5.10.1+dfsg-4_source.buildinfo
Files:
 0a06c2b94532c2b36150f3e68b73f09a 4306 libs optional 
qt3d-opensource-src_5.10.1+dfsg-4.dsc
 f3ac711e463a7c854df150a88b14d70e 56740 libs optional 
qt3d-opensource-src_5.10.1+dfsg-4.debian.tar.xz
 036e30773842a99280a28693eec4d833 12178 libs optional 
qt3d-opensource-src_5.10.1+dfsg-4_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQJIBAEBCAAyFiEEEt36hKwjsrvwSzE8q2RfQGKGp9AFAlrPSPMUHGxpc2FuZHJv
QGRlYmlhbi5vcmcACgkQq2RfQGKGp9DTDA//b4K3/8bRUmNgyRLKQOKrIiJcP+fZ
0j6J3XGqpyoJDTxBbXdhjUconssImU6Cd+XFm2KnVsZHy5QGoRbBmhaYkur7eU7r
mDhhAyEmQnIQYN99zO0BnVjDj3sGEPCUCVe4GOb8YvwOM3YX/hWxOdZwLMh3pqOJ
vzlk6hUbxz23DA59Fc6JkOL1AU0/eKjTsJD8cNb2HqltQsIlJbLf4/Enzf5DrCX3
ORWvBeARsuFMN/pWEvXPozRvbLh+Oz90iprcgaSfgXh0VeYlOqOWVc82P9jRMfZj
rCDzr/H8hYlP5HkK7N+fKV+JepvG91hPh8bFiPUKYiypOO58ib1FwgAjhba7175u
6fHIypzADRmsAgQE1iP4pgmACoErV7gEF6AvlI7uW3Vjgxa+yUS4KF9JNc46TqRY
XuSbY/hKIqlmQv2cg5I3xEsp01CMSsqGoSEA0R5yCaugchisRiUMWbQTw6s/GfXS
XXo0Vwhh3V4leqt9ej6nMD8WSBcJveImE5ORcc4yfzjmh7l/hEKqHSeVS/N1gFzB
N5HI83/Tre5DxwuWZAWzhoaeoUbu2ocyp//Dtlz++XivPfveBVbIH9/xSbrFEekB
bgj1I8cwTKeI9e87Kw9mgct4fHsy2yy8aPa6Miy9JsxHMWc78VY7ADylZBiTqpIM
5M/qfRp/nB9ryRs=
=Ym+0
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to