Your message dated Sat, 14 Apr 2018 02:06:33 +0200
with message-id <20180414000633.gn4...@zira.vinc17.org>
and subject line Re: Processed: [bts-link] source package wget
has caused the Debian Bug report #744170,
regarding wget: Read error in TLS connection with openssl s_server -www server
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
744170: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=744170
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: wget
Version: 1.15-1
Severity: normal

What I set up a test server with:

  openssl s_server -CAfile ... -key ... -cert ... -www

and try wget with it, I get errors:

--2014-04-11 03:30:47--  https://www.vinc17.net:4433/
Resolving www.vinc17.net (www.vinc17.net)... 92.243.22.117, 
2001:4b98:dc0:45:216:3eff:fe9b:eb2f
Connecting to www.vinc17.net (www.vinc17.net)|92.243.22.117|:4433... connected.
HTTP request sent, awaiting response... 200 ok
Length: unspecified [text/html]
Saving to: ‘index.html.2’

    [ <=>                                   ] 5,494       --.-K/s   in 0s      

2014-04-11 03:30:47 (45.7 MB/s) - Read error at byte 5494 (The TLS connection 
was non-properly terminated.).Retrying.

--2014-04-11 03:30:48--  (try: 2)  https://www.vinc17.net:4433/
Connecting to www.vinc17.net (www.vinc17.net)|92.243.22.117|:4433... connected.
HTTP request sent, awaiting response... 200 ok
Length: unspecified [text/html]
Saving to: ‘index.html.2’

    [ <=>                                   ] 5,494       --.-K/s   in 0s      

2014-04-11 03:30:48 (315 MB/s) - Read error at byte 5494 (The TLS connection 
was non-properly terminated.).Retrying.

--2014-04-11 03:30:50--  (try: 3)  https://www.vinc17.net:4433/
Connecting to www.vinc17.net (www.vinc17.net)|92.243.22.117|:4433... connected.
HTTP request sent, awaiting response... 200 ok
Length: unspecified [text/html]
Saving to: ‘index.html.2’

    [ <=>                                   ] 5,494       --.-K/s   in 0s      

2014-04-11 03:30:50 (349 MB/s) - Read error at byte 5494 (The TLS connection 
was non-properly terminated.).Retrying.

--2014-04-11 03:30:53--  (try: 4)  https://www.vinc17.net:4433/
Connecting to www.vinc17.net (www.vinc17.net)|92.243.22.117|:4433... connected.
HTTP request sent, awaiting response... 200 ok
Length: unspecified [text/html]
Saving to: ‘index.html.2’

    [ <=>                                   ] 5,494       --.-K/s   in 0s      

2014-04-11 03:30:54 (573 MB/s) - Read error at byte 5494 (The TLS connection 
was non-properly terminated.).Retrying.
[...]

Firefox, Chromium, curl and w3m do not have a problem with it.

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (500, 'stable'), (1, 
'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.11-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=POSIX, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages wget depends on:
ii  libc6        2.18-4
ii  libgnutls28  3.2.12.1-2
ii  libidn11     1.28-1
ii  libnettle4   2.7.1-1
ii  libuuid1     2.20.1-5.7
ii  zlib1g       1:1.2.8.dfsg-1

Versions of packages wget recommends:
ii  ca-certificates  20140325

wget suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
tags 744170 - fixed-upstream
thanks

On 2018-04-13 22:18:20 +0000, Debian Bug Tracking System wrote:
> > # remote status report for #744170 (http://bugs.debian.org/744170)
> > # Bug title: wget: Read error in TLS connection with openssl s_server -www 
> > server
> > #  * http://savannah.gnu.org/bugs/?func=detailitem&item_id=45792
> > #  * remote status changed: (?) -> Closed
> > #  * remote resolution changed: (?) -> Invalid
> > #  * closed upstream
> > tags 744170 + fixed-upstream

Actually, it's regarded as invalid rather than "fixed-upstream".
I'm closing the bug.

-- 
Vincent Lefèvre <vinc...@vinc17.net> - Web: <https://www.vinc17.net/>
100% accessible validated (X)HTML - Blog: <https://www.vinc17.net/blog/>
Work: CR INRIA - computer arithmetic / AriC project (LIP, ENS-Lyon)

--- End Message ---

Reply via email to