Your message dated Sat, 14 Apr 2018 17:42:51 +0200
with message-id 
<CAJxTCxwPEmikk3nzCJWaF7Nth93Wu4Er8m+Lhs+1UK=sws_...@mail.gmail.com>
and subject line Re: Bug#895672: nodejs: modules can build using ssl 1.0 
symbols but will fail at runtime
has caused the Debian Bug report #895672,
regarding nodejs: modules can build using ssl 1.0 symbols but will fail at 
runtime
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
895672: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895672
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: nodejs
Version: 8.11.1~dfsg-2
Severity: normal

I was building a module using openssl 1.0 (uws) and it doesn't fail
when compiling, but it fails at runtime:
uws_linux_57.node: undefined symbol: SSL_library_init

(the workaround is to just drop that call, but that's not the subject here).

I think the compilation should have failed instead.

-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.15.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8), 
LANGUAGE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages nodejs depends on:
ii  libc-ares2         1.14.0-1
ii  libc6              2.27-3
ii  libgcc1            1:8-20180402-1
ii  libhttp-parser2.8  2.8.1-1
ii  libicu57           57.1-9
ii  libnghttp2-14      1.31.0-1
ii  libssl1.1          1.1.0h-2
ii  libstdc++6         8-20180402-1
ii  libuv1             1.18.0-3
ii  zlib1g             1:1.2.8.dfsg-5

Versions of packages nodejs recommends:
ii  ca-certificates  20180409
ii  nodejs-doc       8.11.1~dfsg-2

nodejs suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Control: forwarded -1 https://github.com/nodejs/node-gyp/issues/1415

2018-04-14 13:29 GMT+02:00 Jérémy Lal <kapo...@melix.org>:

> Package: nodejs
> Version: 8.11.1~dfsg-2
> Severity: normal
>
> I was building a module using openssl 1.0 (uws) and it doesn't fail
> when compiling, but it fails at runtime:
> uws_linux_57.node: undefined symbol: SSL_library_init
>
> (the workaround is to just drop that call, but that's not the subject
> here).
>
> I think the compilation should have failed instead.
>
>
It's an npm (not the npm in debian which is broken anyway) bug: npm
installs its own node-gyp
which installs its own nodejs headers, supposing nodejs 8 is built against
openssl 1.0, which
is not in debian.

Closing.


Jérémy

--- End Message ---

Reply via email to