Your message dated Sat, 14 Apr 2018 19:01:19 +0200
with message-id <20180414170119.gh26...@mykerinos.kheops.frmug.org>
and subject line Re: Bug#895689: Acknowledgement (dl10n-check uses an obsolete 
version comparison ooperator with "dpkg --compare-versions")
has caused the Debian Bug report #895689,
regarding dl10n-check uses an obsolete version comparison ooperator with "dpkg 
--compare-versions"
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
895689: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895689
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: dl10n
Severity: normal
Tags: patch

dl10n-check spits out many warning messages when used (for instance on
i18n.debian.org) :

dpkg: warning: --compare-versions used with obsolete relation operator
'>'

This is indeed quite easy to fix with the attached patch.


-- System Information:
Debian Release: 9.4
  APT prefers oldoldstable
  APT policy: (500, 'oldoldstable'), (500, 'stable'), (500, 'oldstable')
Architecture: i386 (i686)

Kernel: Linux 4.9.0-6-686-pae (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), 
LANGUAGE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: systemd (via /run/systemd/system)

Versions of packages dl10n depends on:
ii  gettext                           0.19.8.1-2
ii  liblocale-gettext-perl            1.07-3+b1
ii  libmailtools-perl                 2.18-1
ii  libtimedate-perl                  2.3000-2
ii  libwww-perl                       6.15-1
ii  perl                              5.24.1-3+deb9u2
ii  perl-modules-5.24 [perl-modules]  5.24.1-3+deb9u2

dl10n recommends no packages.

dl10n suggests no packages.
diff --git a/dl10n-check b/dl10n-check
index 4bad7a1..7b6b0cf 100755
--- a/dl10n-check
+++ b/dl10n-check
@@ -281,7 +281,7 @@ PKG: while ($dsc = shift @pkg_list) {
                 $data->maintainer($pkg, $maint);
                 my $newer = ($data->version($pkg) ne $ver);
                 if ($newer) {
-                        $newer = system ("dpkg","--compare-versions", 
$data->version($pkg), "\>", $ver);
+                        $newer = system ("dpkg","--compare-versions", 
$data->version($pkg), "gt", $ver);
                 }
                 if ((!$force) && $newer==0 && $data->version($pkg) ne ""
                         && !( $force_material &&

--- End Message ---
--- Begin Message ---
Quoting Debian Bug Tracking System (ow...@bugs.debian.org):
> Thank you for filing a new Bug report with Debian.
> 
> You can follow progress on this Bug here: 895689: 
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895689.

Hmmm, OK, already reported and patch proposed....:-)

/me hides....I won't even try merging the bugs....


Attachment: signature.asc
Description: PGP signature


--- End Message ---

Reply via email to