Your message dated Sat, 14 Apr 2018 19:22:14 +0000
with message-id <e1f7qky-000625...@fasolo.debian.org>
and subject line Bug#883620: fixed in roundcube 1.3.6+dfsg.1-1
has caused the Debian Bug report #883620,
regarding roundcube: Since the last upgrade, attachment can't be sent anymore
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
883620: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=883620
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: roundcube
Version: 1.2.3+dfsg.1-4+deb9u1
Severity: normal

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

     Latest Roundcube upgrade

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

     Send a message with an attachment.

   * What was the outcome of this action?

     The attachment is not on the sent message, neither on the
     stored copy in the sent folder.

   * What outcome did you expect instead?

     Attachement sent and stored in the sent folder.

*** End of the template - remove these template lines ***

I get the following error in my log filesĀ :

Dec  5 20:17:59 xxxxxxxx roundcube: <chee9j34> PHP Error: toto can't read 
/tmp/rcmAttmntjoFOF5 (not in temp_dir) in 
/usr/share/roundcube/plugins/filesystem_attachments/filesystem_attachments.php 
on line 216 (POST 
/roundcube/?_task=mail&_unlock=loading1512501479300&_lang=fr&_framed=1&_action=send)

The temp_dir variable is the default:
$config['temp_dir'] = RCUBE_INSTALL_PATH . 'temp/';

So, the problem is that the temp file is created in /tmp, and, since it's not
in the Roundcube configured temp dir (/var/lib/roundcube/temp), roundcube 
removes it...

Configuring the temp_dir variable to /tmp/ solves the issue:
$config['temp_dir'] = '/tmp/';

-- System Information:
Debian Release: 9.1
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-4-amd64 (SMP w/4 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), 
LANGUAGE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages roundcube depends on:
ii  dpkg            1.18.24
ii  roundcube-core  1.2.3+dfsg.1-4+deb9u1

roundcube recommends no packages.

roundcube suggests no packages.

Versions of packages roundcube-core depends on:
ii  dbconfig-common                             2.0.8
ii  debconf [debconf-2.0]                       1.5.61
ii  dpkg                                        1.18.24
ii  libapache2-mod-php                          1:7.0+49
ii  libapache2-mod-php7.0 [libapache2-mod-php]  7.0.19-1
ii  libmagic1                                   1:5.30-1+deb9u1
ii  php-auth-sasl                               1.0.6-3
ii  php-cli                                     1:7.0+49
ii  php-common                                  1:49
ii  php-intl                                    1:7.0+49
ii  php-mail-mime                               1.10.0-2
ii  php-mcrypt                                  1:7.0+49
ii  php-net-smtp                                1.7.1-2
ii  php-net-socket                              1.0.14-2
ii  php-pear                                    1:1.10.1+submodules+notgz-9
ii  php7.0-cli [php-cli]                        7.0.19-1
ii  php7.0-intl [php-intl]                      7.0.19-1
ii  php7.0-json [php-json]                      7.0.19-1
ii  php7.0-mcrypt [php-mcrypt]                  7.0.19-1
ii  roundcube-pgsql                             1.2.3+dfsg.1-4+deb9u1
ii  ucf                                         3.0036

Versions of packages roundcube-core recommends:
ii  php-gd                      1:7.0+49
ii  php-pspell                  1:7.0+49
ii  php7.0-gd [php-gd]          7.0.19-1
ii  php7.0-pspell [php-pspell]  7.0.19-1
ii  spawn-fcgi                  1.6.4-1+b1

Versions of packages roundcube-core suggests:
pn  php-crypt-gpg      <none>
pn  php-net-ldap2      <none>
pn  php-net-ldap3      <none>
ii  roundcube-plugins  1.2.3+dfsg.1-4+deb9u1

-- debconf information:
  roundcube/restart-webserver: true
  roundcube/pgsql/manualconf:
  roundcube/dbconfig-remove: true
  roundcube/language: fr_FR
  roundcube/pgsql/no-empty-passwords:
  roundcube/purge: false
  roundcube/remote/port:
  roundcube/mysql/method: Unix socket
  roundcube/install-error: ignore
* roundcube/db/app-user: roundcube@localhost
* roundcube/pgsql/authmethod-admin: ident
  roundcube/internal/skip-preseed: false
* roundcube/dbconfig-install: false
  roundcube/mysql/admin-user:
  roundcube/db/basepath:
* roundcube/dbconfig-upgrade: true
  roundcube/hosts:
  roundcube/dbconfig-reinstall: false
* roundcube/upgrade-backup: true
  roundcube/remote/host: localhost
  roundcube/pgsql/changeconf: false
* roundcube/upgrade-error: ignore
  roundcube/internal/reconfiguring: false
  roundcube/remove-error: abort
  roundcube/remote/newhost:
* roundcube/pgsql/authmethod-user: password
* roundcube/pgsql/admin-user: postgres
* roundcube/pgsql/method: Unix socket
  roundcube/missing-db-package-error: abort
* roundcube/db/dbname: roundcube
  roundcube/reconfigure-webserver: apache2, lighttpd
  roundcube/passwords-do-not-match:
  roundcube/database-type: pgsql

--- End Message ---
--- Begin Message ---
Source: roundcube
Source-Version: 1.3.6+dfsg.1-1

We believe that the bug you reported is fixed in the latest version of
roundcube, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 883...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Guilhem Moulin <guil...@debian.org> (supplier of updated roundcube package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sat, 14 Apr 2018 20:52:38 +0200
Source: roundcube
Binary: roundcube-core roundcube roundcube-mysql roundcube-pgsql 
roundcube-sqlite3 roundcube-plugins
Architecture: source all
Version: 1.3.6+dfsg.1-1
Distribution: unstable
Urgency: medium
Maintainer: Debian Roundcube Maintainers 
<pkg-roundcube-maintain...@lists.alioth.debian.org>
Changed-By: Guilhem Moulin <guil...@debian.org>
Description:
 roundcube  - skinnable AJAX based webmail solution for IMAP servers - metapack
 roundcube-core - skinnable AJAX based webmail solution for IMAP servers
 roundcube-mysql - metapackage providing MySQL dependencies for RoundCube
 roundcube-pgsql - metapackage providing PostgreSQL dependencies for RoundCube
 roundcube-plugins - skinnable AJAX based webmail solution for IMAP servers - 
plugins
 roundcube-sqlite3 - metapackage providing SQLite dependencies for RoundCube
Closes: 883620 895100 895184
Changes:
 roundcube (1.3.6+dfsg.1-1) unstable; urgency=medium
 .
   * New upstream release. (Closes: #883620).
     + Includes fix for CVE-2018-9846: When the archive plugin enabled and
       configured, it's possible to exploit the unsanitized, user-controlled
       "_uid" parameter to perform an MX (IMAP) injection attack.
       (Closes: #895184).
     + Upgrade OpenPGP.js from 1.6.2 to 2.6.2.
   * debian/control:
     + Bump Standards-Version to 4.1.4 (no changes needed).
     + Remove dependency on 'php-mcrypt' package, which is no longer needed
       since Roundcube 1.2. (Closes: #895100).
   * debian/patches/*.patch: Remove files not mentioned in series:
     + correct-magic-path.patch
     + disable-dns-prefetch.patch
     + dont-limit-email-local-part.patch
     + fix-599586.patch
     + install-jsdeps.sh
     + received-headers-sa.patch
     + too-old-mdb2.patch
     + use-debian-jquery-ui.patch
     + uuencoded-attachments.patch
   * debian/roundcube-core.postinst: Use non-recursive calls to chown(1) and
     chmod(1).
Checksums-Sha1:
 b73de61c6cdbfa40a74f7f000d5b7774fe466ae8 2463 roundcube_1.3.6+dfsg.1-1.dsc
 34fe5958b5b0d647e435c483929509d967fa52e9 3092550 
roundcube_1.3.6+dfsg.1.orig.tar.gz
 943c87a690f060c7d8dde0a74db19f6952433f69 3053276 
roundcube_1.3.6+dfsg.1-1.debian.tar.xz
 bb2ee8c99f061a09757d9c2ca73d134016553bfc 2222480 
roundcube-core_1.3.6+dfsg.1-1_all.deb
 17b742718bfe0495822a591c37cf70ee8b3176b6 77352 
roundcube-mysql_1.3.6+dfsg.1-1_all.deb
 97ee378f0251646fa9b435d9d69fd28a553b74ff 77324 
roundcube-pgsql_1.3.6+dfsg.1-1_all.deb
 2d6f82390055e9895aeb2aaf175ee3e3366ebe39 1001456 
roundcube-plugins_1.3.6+dfsg.1-1_all.deb
 1bc007cb6302b62f4f2a183e06421c7adeae6472 77304 
roundcube-sqlite3_1.3.6+dfsg.1-1_all.deb
 85f90266ce3a7529353e284af026cc4e47973ce2 1440 roundcube_1.3.6+dfsg.1-1_all.deb
 f7038528b680c1219d6d6cf12eaf5c28c5a202a3 8808 
roundcube_1.3.6+dfsg.1-1_amd64.buildinfo
Checksums-Sha256:
 2fc58fe481582d3ca4dbdab6ce812f2a26324eb870464be5fd1d8bb1d2da9a7d 2463 
roundcube_1.3.6+dfsg.1-1.dsc
 d486394ae05a9295d1ca6a238fcf36bbfcd10b547b3c2c9127e1d1fb08b998be 3092550 
roundcube_1.3.6+dfsg.1.orig.tar.gz
 9abb7599c66d233788bf5751dbc57c735ff299ee809df10bf9733e9d68a0b7d3 3053276 
roundcube_1.3.6+dfsg.1-1.debian.tar.xz
 af7be03034a2c9628eec0e5b0ff042c7101977e9c27c9d51733af01f4af523db 2222480 
roundcube-core_1.3.6+dfsg.1-1_all.deb
 2b866f9c5ce474e0c2b022af47597ce3b4558a44c2991cddf421a4a3436b7423 77352 
roundcube-mysql_1.3.6+dfsg.1-1_all.deb
 0f31798adf16e7e9053192ab4203b882922aa093237a6a7de14b93e0f541a2d1 77324 
roundcube-pgsql_1.3.6+dfsg.1-1_all.deb
 529fbfd424dfd5dd762ed3e7b4c1ea816461b301a2c9b43132393e22654902ab 1001456 
roundcube-plugins_1.3.6+dfsg.1-1_all.deb
 5a9298312c883bf5d9fc7f635b051e52e99a1423e43a7431dd38addcf5b2059b 77304 
roundcube-sqlite3_1.3.6+dfsg.1-1_all.deb
 61cc430e09d178b2f044d9019da4efec577c3ea9457d363b012e037089fd4fdb 1440 
roundcube_1.3.6+dfsg.1-1_all.deb
 062eb8e14dbf0e6490189060c2916df0cb819079e0f72ba3b3eb37234c9e371f 8808 
roundcube_1.3.6+dfsg.1-1_amd64.buildinfo
Files:
 6df63e1def80543d1aa5f0a8d7409628 2463 web optional roundcube_1.3.6+dfsg.1-1.dsc
 1560a5fcc55bbd0681d3eda00f978704 3092550 web optional 
roundcube_1.3.6+dfsg.1.orig.tar.gz
 69a9e3fd26874d90e8dc3dbc87d4bfe4 3053276 web optional 
roundcube_1.3.6+dfsg.1-1.debian.tar.xz
 2719de9263f2cf05491ef766eee55067 2222480 web optional 
roundcube-core_1.3.6+dfsg.1-1_all.deb
 cb05528bfe859a473256c01ba7948c6c 77352 web optional 
roundcube-mysql_1.3.6+dfsg.1-1_all.deb
 276cc51b17c763e155c31123839361eb 77324 web optional 
roundcube-pgsql_1.3.6+dfsg.1-1_all.deb
 f172f312d5c43e96f7bebac5f571d7ef 1001456 web optional 
roundcube-plugins_1.3.6+dfsg.1-1_all.deb
 c5fdd77647e66e75d74464b7278bf5b8 77304 web optional 
roundcube-sqlite3_1.3.6+dfsg.1-1_all.deb
 b4a3af5d4596abf9983daee76d926d27 1440 web optional 
roundcube_1.3.6+dfsg.1-1_all.deb
 45dbed5093f96dd740bc60e1d71c4919 8808 web optional 
roundcube_1.3.6+dfsg.1-1_amd64.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEERpy6p3b9sfzUdbME05pJnDwhpVIFAlrSTmMACgkQ05pJnDwh
pVJsCRAAu7wDx43l8gS2G3xbRc+bKMIS22u4sNzdZ5glLaIfpMnZ+lCbz64To9C2
hSPCXN4o7PaFYnyunfdrtTGJBZD5EvOFBpajGO6PMoBqVsZdUtn7NCdBft3zRwlE
o2/vel1Ix/P+4yv+ZVQYWnsLyv/u05JIOX9nCElol5FYB1i5f4Aag6CQhgx5zVbv
vLUCJ3A5gh4Q4qAQK6g39zUXpa6zpr02QN8D2Wc3xFYt5lmunvZwBBg9KaxuiwxE
EeC1Bihe8AU6PFn6AptiNSKq506H/8jE61aWkP+1jKxDohIZdIivkKYxi9MZ03dY
K5FmxApLraRV3XKqt22fyVPHACBa9xy5KvCCqNyYRUOjNw5mI/lR3OrpFn6HYBa8
KYBQ0qA1o4qY+ms4F+0F0UshAbqIIbh25j/quGjW13ikGYF8sVfgo07+cIpfL1bW
L0fKpV7odBnIcy4JuNyEYnM/LpaebMd4gA04b60oI6RgXl3RCqxdjFBITuD/XBW2
nHIK/wHLGVUIJP/uhRiWfdlBbXCMx5VA63ovvT7pxYKAbbXYhkRJyq+imaHDBvGr
FEv+l2H4ChOjLg+LITiq+5+gUOnO4Fm/cFHydEh+ac8dRFfgtxVZiLJV2jl/ZeJj
E/BABtxRB15GNT12JthhA+GIIqEDjJPA8+eMplla/aBU3IZBEY0=
=mqzx
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to