Your message dated Sun, 15 Apr 2018 19:21:29 +0000
with message-id <e1f7ndn-000itd...@fasolo.debian.org>
and subject line Bug#895738: fixed in sphinx 1.7.2-3
has caused the Debian Bug report #895738,
regarding python3-sphinx: missing dependency on python3-setuptools
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
895738: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895738
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: python3-sphinx
Version: 1.7.2-1
Severity: important

This morning I upgraded python3-sphinx in a sid chroot:

[UPGRADE] python3-sphinx:amd64 1.6.7-2 -> 1.7.2-1

Following that upgrade, it no longer works:

Traceback (most recent call last):
  File "/usr/bin/sphinx-build", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 3088, 
in <module>
    @_call_aside
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 3072, 
in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 3101, 
in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 574, in 
_build_master
    ws.require(__requires__)
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 892, in 
require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 778, in 
resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'setuptools' distribution was not found 
and is required by Sphinx

The problem seems to be a missing dependency on python3-setuptools:

$ apt-cache show python3-sphinx |grep ^Depends
Depends: python3:any (>= 3.4~), python3-lib2to3, python3-distutils, python3-six 
(>= 1.5), python3-docutils (>= 0.11), python3-pygments (>= 2.0), python3-jinja2 
(>= 2.3), python3-babel (>= 1.3), python3-alabaster (>= 0.7), 
python3-imagesize, python3-requests (>= 2.4.0), python3-packaging, 
sphinx-common (= 1.7.2-1)

After manually installing python3-setuptools it started working again.

Regards,

-Roberto

-- 
Roberto C. Sánchez

Attachment: signature.asc
Description: PGP signature


--- End Message ---
--- Begin Message ---
Source: sphinx
Source-Version: 1.7.2-3

We believe that the bug you reported is fixed in the latest version of
sphinx, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 895...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Dmitry Shachnev <mity...@debian.org> (supplier of updated sphinx package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Sun, 15 Apr 2018 21:43:18 +0300
Source: sphinx
Binary: python-sphinx python3-sphinx sphinx-common sphinx-doc libjs-sphinxdoc
Architecture: source
Version: 1.7.2-3
Distribution: unstable
Urgency: medium
Maintainer: Debian Python Modules Team 
<python-modules-t...@lists.alioth.debian.org>
Changed-By: Dmitry Shachnev <mity...@debian.org>
Description:
 libjs-sphinxdoc - JavaScript support for Sphinx documentation
 python-sphinx - documentation generator for Python projects (implemented in 
Pytho
 python3-sphinx - documentation generator for Python projects (implemented in 
Pytho
 sphinx-common - documentation generator for Python projects - common data
 sphinx-doc - documentation generator for Python projects - documentation
Closes: 895738
Changes:
 sphinx (1.7.2-3) unstable; urgency=medium
 .
   * Remove setuptools from install_requires, it is not needed on Debian
     (closes: #895738).
Checksums-Sha1:
 0faa6abbbd1668967ae83ffa506ad77ecb410b21 3754 sphinx_1.7.2-3.dsc
 6422acca0eb633df034dc6cbeb3035c66191c6d5 35856 sphinx_1.7.2-3.debian.tar.xz
 5e77a7c1d21863effdd90e364db7544503838d7d 5094 sphinx_1.7.2-3_source.buildinfo
Checksums-Sha256:
 8194f5f0525330a6e15389c27eb2c94996fa82ccecc6ff11f03ff82e8798a44d 3754 
sphinx_1.7.2-3.dsc
 52ec2a4191fb6a5ba04718290e5876b90f7e134cb02827f64ece5ce52e585273 35856 
sphinx_1.7.2-3.debian.tar.xz
 650165ebfceac58f7497ad5435e31f194dce1b2a2f77b0154bd8c6337516cfef 5094 
sphinx_1.7.2-3_source.buildinfo
Files:
 63568c24d96cc1c0114950c8579f0a0a 3754 python optional sphinx_1.7.2-3.dsc
 dea6d3658b3a4845e52873f1307552e6 35856 python optional 
sphinx_1.7.2-3.debian.tar.xz
 0f8368596141ae33b8c5503ceb1cdabe 5094 python optional 
sphinx_1.7.2-3_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEbEPcK+5mZmLK5jNU1v5xA2P4XdMFAlrTnuAACgkQ1v5xA2P4
XdMhOA/+M9nnh8XRJTQUJLf668iw2rToqBQDZFo3gRcNfWYJVjdV+m2NTjOB0t8U
nneE3MpM8StfkrG4XvSoYSf5EtgMzGdvVivkO2MsEswmosUPRNRfWv8cKQtG6u54
a19Bixv5PyqVjW7lTFkafI4TnG8MJkPYEZx0Gb/QLk6/SjH2Yo163UFQmtNmzFDK
Z+9TeIpHq9HmOPGZ6BY/u/n67SdOslckf1YVLhHWAqxPC3naF4dWDBlv/NW6o9y8
dU4O1VQ3p+2ziStEJNLycIPfXLRssxg75nexXSQxH2yOkHZ1KNlkIbnyspJDxREr
JVIpB/nB9IN/k/IeCAlLZ7K2aqJ5WeS2DyLmrPiG7P/hoi0wR6qmPUCoF+nSII5s
sI3NrkYsxmFKksuX/J/glAPyEP449+FIAUR8zcNzrshqm95XoM5MpgghwgtKSD+c
H5q31j17Jeyx6sckkVlPvIcxODLcCS8KXUViSUx1GoctnMkch7m+Qpnzqnu1cWQi
Kqh6/rB5dQSsh4DogiuEkxFZfZbSRQWbIliHAblnSk9E0RDNKitn6S+FyoxqU7FY
IHlCk0B2Djum2vGTWG5a5GfB5tG5hgYV25XKAjsac2GrWc7PON4DBB2tYRb6DeOq
k8MhQhsy/JQrbTyzaWBWWRCWQuyQOINGU6tPWTsdr1RCYd9GM08=
=YbDp
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to