Your message dated Mon, 16 Apr 2018 08:31:15 -0400
with message-id 
<caaajcma8vurf06kxbmobgd2jh8sazenm6k5zq7cgwy6bths...@mail.gmail.com>
and subject line Re: Bug#895000: atril always shows a stacktrace/crash from 
webkit displaying pdf files
has caused the Debian Bug report #895000,
regarding atril always shows a stacktrace/crash from webkit displaying pdf files
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
895000: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895000
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: atril
Version: 1.20.1-1
Severity: minor

Hi.

First of all, please, change this bug report to anothe package if
appropriate (but I don't see this problem with evince, though).

Second, I am setting the severity of this bug to minor only because I
haven't seen further problems with it and I am not using atril to read epub
books (and I don't know if that would change the result).

When running atril with *any* PDF file, I see a stack trace like the
following:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
$ atril test.pdf 
Gtk-Message: 00:14:29.194: Failed to load module "canberra-gtk-module"
Gtk-Message: 00:14:29.564: Failed to load module "canberra-gtk-module"
1   0x7f598ae7b807 
/usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-4.0.so.18(WTFCrash+0x17) 
[0x7f598ae7b807]
2   0x7f598eff3adf /usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37(+0x766adf) 
[0x7f598eff3adf]
3   0x7f598eff533c /usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37(+0x76833c) 
[0x7f598eff533c]
4   0x7f598f12ce0a /usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37(+0x89fe0a) 
[0x7f598f12ce0a]
5   0x7f598f12ab1d /usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37(+0x89db1d) 
[0x7f598f12ab1d]
6   0x7f598ee7e5fb /usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37(+0x5f15fb) 
[0x7f598ee7e5fb]
7   0x7f598ee7eee5 /usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37(+0x5f1ee5) 
[0x7f598ee7eee5]
8   0x7f598ae965c3 
/usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3WTF7RunLoop11performWorkEv+0xf3)
 [0x7f598ae965c3]
9   0x7f598aebf619 
/usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-4.0.so.18(+0xe51619) 
[0x7f598aebf619]
10  0x7f598bcad0f5 
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x155) 
[0x7f598bcad0f5]
11  0x7f598bcad4c0 /lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x4c4c0) 
[0x7f598bcad4c0]
12  0x7f598bcad7d2 /lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_loop_run+0xc2) 
[0x7f598bcad7d2]
13  0x7f598aebffc0 
/usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-4.0.so.18(_ZN3WTF7RunLoop3runEv+0x100)
 [0x7f598aebffc0]
14  0x7f598f2e1628 /usr/lib/x86_64-linux-gnu/libwebkit2gtk-4.0.so.37(+0xa54628) 
[0x7f598f2e1628]
15  0x7f598e1d8a87 /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7) 
[0x7f598e1d8a87]
16  0x5609d14e095a 
/usr/lib/x86_64-linux-gnu/webkit2gtk-4.0/WebKitWebProcess(_start+0x2a) 
[0x5609d14e095a]
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

The first line is the most curious (WTFCrash :-))... Just for reference,
when I run with evince, this is what I get:

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
$ evince test.pdf 
Gtk-Message: 00:22:50.170: Failed to load module "canberra-gtk-module"
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

If any further information is needed, please let me know.


Thanks,

Rogério.

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing'), (200, 'unstable'), (150, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.15.0-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.utf-8, LC_CTYPE=pt_BR.utf-8 (charmap=UTF-8), 
LANGUAGE=en_US.utf-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages atril depends on:
ii  atril-common                                 1.20.1-1
ii  dconf-gsettings-backend [gsettings-backend]  0.26.1-3
ii  libatk1.0-0                                  2.28.1-1
ii  libatrildocument3                            1.20.1-1
ii  libatrilview3                                1.20.1-1
ii  libc6                                        2.27-3
ii  libcairo-gobject2                            1.15.10-1
ii  libcairo2                                    1.15.10-1
ii  libcaja-extension1                           1.20.0-2
ii  libgail-3-0                                  3.22.29-2
ii  libgdk-pixbuf2.0-0                           2.36.11-2
ii  libglib2.0-0                                 2.56.0-4
ii  libgtk-3-0                                   3.22.29-2
ii  libice6                                      2:1.0.9-2
ii  libjavascriptcoregtk-4.0-18                  2.20.0-2
ii  libpango-1.0-0                               1.42.0-1
ii  libpangocairo-1.0-0                          1.42.0-1
ii  libsecret-1-0                                0.18.6-1
ii  libsm6                                       2:1.2.2-1+b3
ii  libsoup2.4-1                                 2.62.0-1
ii  libwebkit2gtk-4.0-37                         2.20.0-2
ii  libx11-6                                     2:1.6.5-1
ii  libxml2                                      2.9.4+dfsg1-6.1
ii  mate-desktop-common                          1.20.0-1
ii  shared-mime-info                             1.9-2
ii  zlib1g                                       1:1.2.8.dfsg-5

Versions of packages atril recommends:
ii  dbus-user-session [default-dbus-session-bus]  1.12.6-2
ii  dbus-x11 [dbus-session-bus]                   1.12.6-2
ii  gvfs                                          1.36.0-1

Versions of packages atril suggests:
ii  caja          1.20.0-2
ii  poppler-data  0.4.8-2
pn  unrar         <none>

-- no debconf information

-- 
Rogério Brito : rbrito@{ime.usp.br,gmail.com} : GPG key 4096R/BCFCAAAA
http://cynic.cc/blog/ : github.com/rbrito : profiles.google.com/rbrito
DebianQA: http://qa.debian.org/developer.php?login=rbrito%40ime.usp.br

--- End Message ---
--- Begin Message ---
Version: 2.20.1-1

On Mon, Apr 16, 2018 at 8:26 AM, Alberto Garcia <be...@igalia.com> wrote:
> On Fri, Apr 13, 2018 at 02:00:05PM -0400, Jeremy Bicha wrote:
>> Version: 2.20.1-1
>>
>> The webkit2gtk developers believe this is already fixed in webkit2gtk
>> 2.20.1 which should reach Testing in a few days.
>
> Can this bug be closed then, or what's the situation?

Yes, sorry I meant to close this bug with my previous comment.

Thanks,
Jeremy Bicha

--- End Message ---

Reply via email to