Your message dated Sat, 11 Aug 2018 21:43:02 +0200
with message-id <20180811194302.dtt6z66mworax...@percival.namespace.at>
and subject line Re: #726420: multipath-tools: Fails to upgrade in 
root-on-multipath setups
has caused the Debian Bug report #726420,
regarding multipath-tools: Fails to upgrade in root-on-multipath setups
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
726420: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=726420
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: multipath-tools
Version: 0.4.9+git0.4dfdaf2b-6
Severity: normal

Hi,

The Debian 7.1 -> 7.2 upgrade includes a multipath-tools upgrade,
which fails on a multipath-rooted system:

Preparing to replace multipath-tools 0.4.9+git0.4dfdaf2b-6 (using 
.../multipath-tools_0.4.9+git0.4dfdaf2b-7~deb7u1_amd64.deb) ...
[....] Root is on a multipathed device, multipathd can not be 
stopped:invoke-rc.d: initscript multipath-tools, action "stop" failed.
dpkg: warning: subprocess old pre-removal script returned error exit status 1
dpkg: trying script from the new package instead ...
[....] Root is on a multipathed device, multipathd can not be 
stopped:invoke-rc.d: initscript multipath-tools, action "stop" failed.
dpkg: error processing 
/var/cache/apt/archives/multipath-tools_0.4.9+git0.4dfdaf2b-7~deb7u1_amd64.deb 
(--unpack):
 subprocess new pre-removal script returned error exit status 1

Ignoring the stop failure in the prerm script fixes the problem.
-- 
Regards,
Feri.

--- End Message ---
--- Begin Message ---
As described by the submitter, this really is a bug in the package
in 7.1, and there is nothing we can do to improve upgrades _from_
7.1. As this about oldoldstable, I'll just close this bug now.

Thanks everyone,
Chris

--- End Message ---

Reply via email to