Your message dated Sun, 12 Aug 2018 02:12:36 +0200
with message-id <>
and subject line Re: Bug#580312: multipath-tools: multipathd segfaults when 
has caused the Debian Bug report #580312,
regarding multipath-tools: multipathd segfaults when restarted
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: multipath-tools
Version: 0.4.8-14+lenny2
Severity: normal

*** Please type your report below this line ***

I have a simple setup with a Promise VTrak E610f direct-connected
to a Dell 2950 with LSI FC949SE card. There is only one FC connection.
Two LUNs are exposed by the Promise.

# multipath -l
mpath1 (2227300015530e20d) dm-1 Promise ,VTrak E610f [size=13T][features=1 queue_if_no_path][hwhandler=0]
\_ round-robin 0 [prio=0][active]
 \_ 0:0:0:1 sdf 8:80  [active][undef]
 mpath0 (2228f000155e2acda) dm-0 Promise ,VTrak E610f
 [size=13T][features=1 queue_if_no_path][hwhandler=0]
 \_ round-robin 0 [prio=0][active]
  \_ 0:0:0:0 sda 8:0   [active][undef]

When rebooting, or sometimes doing /etc/init.d/multipath-tools restart,
multipathd segfaults, e.g.
  kernel: [  511.240204] multipathd[6331]: segfault at ffffffff00645a68 ip 
7ffe3777ea0e sp 4000fd30 error 4 in[7ffe3770b000+14a000]

and another
  kernel: [ 1150.730222] multipathd[6379]: segfault at a ip 7f02665569fb sp 
7fffffffe0a0 error 4 in[7f02664e3000+14a000]

It doesn't occur reliably.
I've tried with and without the /dev/mapper/mpathN-part1 partitions mounted. I haven't tried restarting/rebooting when under load.

This may be the same bug as 519252. If so, it seems it isn't quite fixed.
I have a system available for testing but it needs to run lenny packages
or lenny-backports in a pinch.

Kind regards

-- Package-specific info:
Contents of /etc/multipath.conf:
defaults {
        user_friendly_names     yes
blacklist {
        devnode "^(ram|raw|loop|fd|md|dm-|sr|scd|st)[0-9]*"
        devnode "^hd[a-z][[0-9]*]"
        devnode "^cciss!c[0-9]d[0-9]*[p[0-9]*]"
        device {
                vendor MegaRAID
        device {
                vendor APPLE
        device {
                vendor ATA
        device {
                vendor DELL
devices {
        device {
                vendor                  "Promise"
                product                 "VTrak"
                path_grouping_policy    multibus
                getuid_callout          "/lib/udev/scsi_id -g -u -s /block/%n"
                path_checker            readsector0
                path_selector           "round-robin 0"
                hardware_handler        "0"
                failback                immediate
                rr_weight               uniform
                rr_min_io               100
                no_path_retry           20
                features                "1 queue_if_no_path"
                product_blacklist       "VTrak V-LUN"

-- System Information:
Debian Release: 5.0.4
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages multipath-tools depends on:
ii  initscripts              2.86.ds1-61     Scripts for initializing and shutt
ii  kpartx                   0.4.8-14+lenny2 create device mappings for partiti
ii libaio1 0.3.107-3 Linux kernel AIO access library - ii libc6 2.7-18lenny2 GNU C Library: Shared libraries
ii  libdevmapper1.02.1       2:1.02.27-4     The Linux Kernel Device Mapper use
ii  libncurses5              5.7+20081213-1  shared libraries for terminal hand
ii  libreadline5             5.2-3.1         GNU readline and history libraries
ii  lsb-base                 3.2-20          Linux Standard Base 3.2 init scrip
ii  udev                     0.125-7+lenny3  /dev/ and hotplug management daemo

multipath-tools recommends no packages.

Versions of packages multipath-tools suggests:
pn  multipath-tools-boot          <none>     (no description available)

-- no debconf information

--- End Message ---
--- Begin Message ---
* Vincent McIntyre <> [180812 01:46]:
> On Sat, Aug 11, 2018 at 05:09:58PM +0200, Chris Hofstaedtler wrote:
> > Do you still see this in current versions?
> No, have not seen this occur again like this that I can recall;
> we would have followed up to this bug if we had.
> I think this bug can probably be closed, the code has improved
> enormously since this occurred and nobody else seems to have hit it.

Thanks, closing therefore.


--- End Message ---

Reply via email to