Your message dated Wed, 15 Jan 2020 00:00:32 +0100
with message-id <87zhepfxtb.fsf@localhost>
and subject line Re: Bug#833962: blender: Doesn't work input with russian 
characters into text editor.
has caused the Debian Bug report #833962,
regarding blender: Doesn't work input with russian characters into text editor.
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
833962: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=833962
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: blender
Version: 2.79+dfsg0-3+b1
Severity: important
Tags: l10n

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?
       - installed the blender via apt-get from repository of Kali. 
         please note that this packages is an unmodified one from Debian


   * What exactly did you do (or not do) that was effective (or
     ineffective)?

       - in blender created a text object(On the left pane select tab Create, 
(scroll down), find "Other" section, click  "Text"
         then on the bottom pane click on "Object Mode" drop down, select "Edit 
mode", notice non blinking cursor appearance
         on the rendered text object, then put russian character or english 
characters with keyboard; nothing will
         be displayed, while normal editing commands(like delete) and putting 
non-russian text works)

         tried to edit and enter a russian character and failed to do so. 
         Russian character are displayed in the UI of blender fine but are not 
rendered.
         no matter what I do I can't make it work for this one need to install 
the keyboard switcher

       - I am able to see the Russian characters in the UI of blender, however, 
not in the render of 
         the text object. 
       - in the output of blender noticed, that following error messages are 
displayed:

[Tue Jan  9 08:57:51 UTC 2018]:~$ blender -d
Switching to fully guarded memory allocator.
Blender 2.79 (sub 0)
argv[0] = blender
argv[1] = -d
read file /home/puni/.config/blender/2.79/config/userpref.blend
  Version 279 sub 0 date unknown hash unknown
Read prefs: /home/puni/.config/blender/2.79/config/userpref.blend
read file 
  Version 272 sub 2 date unknown hash unknown

ordered
 OBCube
 OBLamp
 OBCamera
BLF_get_unifont: 'Dejavu Sans' font not found with fontconfig
BLF_get_unifont_mono: 'Dejavu Sans Mono' font not found with fontconfig

       - I am suspecting that this behaviour has something to do with the 
following thread:
         https://developer.blender.org/T53106
         and following patch:
         
https://anonscm.debian.org/cgit/pkg-multimedia/blender.git/tree/debian/patches/0006-look_for_dejavu_ttf_with_fontconfig.patch?h=debian/2.79%2bdfsg0-2
         Lines 186 and 220 

         To me it seems that an attempt was made to load another font, however, 
it is failing. 
         This or similair bug was reported earlier and is not marked as fixed: 
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=833962

       - Note: On my system I see that fc-list has "Dejavu*" while the patch 
expects "DejaVu", not sure if this is root cause.
         See the following output from fc-list:

[Tue Jan  9 08:24:01 UTC 2018]:~/bin$ fc-list | grep -i "Dejavu Sans Mono"
/usr/share/fonts/truetype/dejavu/DejaVuSansMono.ttf: DejaVu Sans Mono:style=Book
/usr/share/fonts/truetype/dejavu/DejaVuSansMono-Oblique.ttf: DejaVu Sans 
Mono:style=Oblique
/usr/share/fonts/truetype/dejavu/DejaVuSansMono-BoldOblique.ttf: DejaVu Sans 
Mono:style=Bold Oblique
/usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Bold.ttf: DejaVu Sans 
Mono:style=Bold
/usr/share/fonts/truetype/dejavu/DejaVuSansMono-Bold.ttf: DejaVu Sans 
Mono:style=Bold
/usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono.ttf: DejaVu Sans 
Mono:style=Book

   * What was the outcome of this action?
         - I have failed to add a russian character into the text object of 
blender

   * What outcome did you expect instead?
         - I expected to see russian character added in blender 
         - As I am not 100% sure on the origin of the issue I have also 
submitted this report:
           https://developer.blender.org/T53744

*** End of the template - remove these template lines ***


-- System Information:
Distributor ID: Kali
Description:    Kali GNU/Linux Rolling
Release:        kali-rolling
Codename:       kali-rolling
Architecture: x86_64

Kernel: Linux 4.14.0-kali1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages blender depends on:
ii  blender-data                      2.79+dfsg0-3
ii  fonts-dejavu                      2.37-1
ii  libavcodec57                      7:3.4.1-1+b1
ii  libavdevice57                     7:3.4.1-1+b1
ii  libavformat57                     7:3.4.1-1+b1
ii  libavutil55                       7:3.4.1-1+b1
ii  libboost-atomic1.62.0             1.62.0+dfsg-4+b2
ii  libboost-chrono1.62.0             1.62.0+dfsg-4+b2
ii  libboost-date-time1.62.0          1.62.0+dfsg-4+b2
ii  libboost-filesystem1.62.0         1.62.0+dfsg-4+b2
ii  libboost-iostreams1.62.0          1.62.0+dfsg-4+b2
ii  libboost-locale1.62.0             1.62.0+dfsg-4+b2
ii  libboost-regex1.62.0              1.62.0+dfsg-4+b2
ii  libboost-system1.62.0             1.62.0+dfsg-4+b2
ii  libboost-thread1.62.0             1.62.0+dfsg-4+b2
ii  libc6                             2.25-5
ii  libfftw3-double3                  3.3.7-1
ii  libfontconfig1                    2.12.6-0.1
ii  libfreetype6                      2.8.1-0.1
ii  libgcc1                           1:7.2.0-18
ii  libgl1                            1.0.0-1
ii  libglew2.0                        2.0.0-5
ii  libglu1-mesa [libglu1]            9.0.0-2.1
ii  libgomp1                          7.2.0-18
ii  libilmbase12                      2.2.0-12
ii  libjack-jackd2-0 [libjack-0.125]  1.9.10+20150825git1ed50c92~dfsg-5
ii  libjemalloc1                      3.6.0-11
ii  libjpeg62-turbo                   1:1.5.2-2+b1
ii  libopenal1                        1:1.17.2-4+b2
ii  libopencolorio1v5                 1.0.9~dfsg0-12
ii  libopenexr22                      2.2.0-11.1
ii  libopenimageio1.8                 1.8.6~dfsg0-4
ii  libopenjp2-7                      2.3.0-1
ii  libopenvdb5.0                     5.0.0-1
ii  libpcre3                          2:8.39-8
ii  libpng16-16                       1.6.34-1
ii  libpython3.6                      3.6.4~rc1-1
ii  libsndfile1                       1.0.28-4
ii  libspnav0                         0.2.3-1
ii  libstdc++6                        7.2.0-18
ii  libswscale4                       7:3.4.1-1+b1
ii  libtbb2                           2017~U7-8
ii  libtiff5                          4.0.9-3
ii  libx11-6                          2:1.6.4-3
ii  libxi6                            2:1.7.9-1
ii  libxml2                           2.9.4+dfsg1-5.2
ii  libxxf86vm1                       1:1.1.4-1+b2
ii  python3                           3.6.3-2
ii  zlib1g                            1:1.2.8.dfsg-5

blender recommends no packages.

blender suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 2.81.a+dfsg-3

On 2016-08-11 at 01:19 (+03), Vladislav wrote:
> Version: 2.77.a+dfsg0-7+b1
>
> Dear Maintainer,
>
>    * What led up to the situation?
>         -command: "sudo aptitude update" than "sudo aptitude upgrade"
>    * What exactly did you do (or not do) that was effective (or
>      ineffective)?
>         -added several layouts of keyboard.
>    * What was the outcome of this action?
>         -Layouts with Latin characters work properly (Japanese, Czech, 
> English)
> - text succsesfully writes into Blender's text editor;
>          layouts with other characters (partially - Cyrrilic (more partially -
> Russian)) doesn't make any input into Blender's text editor.
>    * What outcome did you expect instead?
>         -When I type with Russian layout, proper character are written into 
> the
> Blender's text editor.

I've tried to reproduce this issue on latest release and it seems to be
fixed.

Thus, closing. But feel free to reopen in case I simply missed the point
and the problem is still there.

Cheers.


-- 
Matteo F. Vescovi

Attachment: signature.asc
Description: PGP signature


--- End Message ---

Reply via email to