On Wed, Sep 14, 2016 at 08:59:52AM +0200, Aurelien Jarno wrote:
> > More details.
> > The target system is pxe booted and next-server takes it to a (debian)
> > system running tftpd-hpa. The defaults.cfg has lots of boot targets
> > but the one I have been testing with is the netboot image, in manual
> > install mode. The only boot options it is given are 
> >  'append vga=normal initrd=yadayada'
> > It also falls over if I feed it a preseed file, where we use
> >  'append auto=true priority=critical vga=normal initrd=yadayda 
> >   url=blahdeblah'
> Thanks for the details. Here in a QEMU VM, both work fine.

I learned today that this whole goose chase started when
a colleague hit this using qemu and bridged networking.
Before today I thought it was real hardware.

I tried this with vmware fusion, setting next-server to the pxe
server used above and the manual/interactive installer target.
I was using NATted networking here; resolv.conf lists only the
vmware nameserver (

busybox segfaults at the same time and in the same way.
If I test with wget or ping, I get a segfault unless I use IP
addresses or add the hostname I want to resolve to /etc/hosts.

I tried patching the initrd so that the hostname and lookup
could be pre-configured. /etc/nsswitch.conf comes through
unscathed but /etc/hosts is overwritten. When I hit the segfault
I added the necessary /etc/hosts entry and retried. That worked;
I was able to do a complete installation.

I also figured out how to use netcat to get the log file.
I've attached the syslog up to the first segfault,

Attachment: syslog.debug=5.gz
Description: application/gzip

Reply via email to