My first through was the common Debian situation where there's a
mismatch between libwacom2 (which lags releases regularly) and GNOME
(which advances fast). It may well not be libwacom at fault, but
without a debugging trace we can't tell yet. A recent update to
libwacom 0.22 doesn't fix this issue, however. See also Bug#838047 < >.

This breaks gnome-shell with all the Wacom and non-Wacom graphics
tablets I've tried, crashing gnome-shell at or shortly after the point
when they are connected. However the non-tablet USB devices I've tried
seem OK, including my (non-Wacom, non-pen, regular multitouch)
touchscreen. See bug 838047 for details and log traces.

I cannot get the suggested rmmod workaround to work on my system. The
non-Wacom tablets still cause gnome-shell to crash immediately upon
being plugged in, and when a Wacom tablet is plugged in, the "wacom"
kernel module is automatically loaded and stays loaded.

I am using Wayland gdm3, and Xorg user gnome-shell sessions.

gnome-shell   3.21.91-2
gdm3   3.21.90-1
libwacom2   0.22-1

Andrew Chadwick

Reply via email to