Hi Michal,

On Tue, Sep 20, 2016 at 2:27 PM, Michal Čihař <mic...@cihar.com> wrote:
> this build failure is caused by mismatching versions of libpq-dev
> and postgresql used in the build.
 I know, should have contacted the PostgreSQL team already.

> This is still problem in current sid:
>
> postgresql is 9.5 while libpq-dev is 9.6
>
> Possible ways to address it:
>
> - make postgresql packaging consistent
 This should be done as it may break other packages as well. Maybe
those are not yet uncovered.

> - do not use pg_config to figure out binary path
 If you know any other way, please let me know.

> - Build-Depend on specific version (postgresql-9.6)
 This mean I'll have to do a libdbi-drivers upload for every
PostgreSQL version change - just changing -9.6 to -9.7 and so on. This
package is not specific to any PSQL release and should be totally
unrelated to its current version number.

> As the last choice is least intrusive, I will probably NMU it  unless
> there will be some objections. See attached diff.
 Can be, but the worst solution as you can see above. Let me ask what
the PostgreSQL maintainers say.

Regards,
Laszlo/GCS

Reply via email to