On Tue, 11 Oct 2016 06:33:06 +0200
Helmut Grohne <hel...@subdivi.de> wrote:

> Hi Holger,
> 
> On Mon, Oct 10, 2016 at 09:30:35PM +0000, Holger Levsen wrote:
> > this seems a fairly strong statement, considering
> > https://tracker.debian.org/pkg/dpkg-cross shows not a single bug
> > filed against the package.  

I could file 15 RC bugs against dpkg-cross for the flagrant
disregard of ALL Debian Policy, if you really want proof of the
abominations that hide within it. However, cross-config has none of
those issues, so to allow cross-config to exist in Stretch I want to
see the removal of the dpkg-cross and libdebian-dpkgcross-perl binary
packages instead. These should have been removed from Debian before we
released Lenny, let alone Jessie. Yay for the inertia of cross-building
in Debian.

cross-config exists solely to allow the removal of the dpkg-cross and
libdebian-dpkgcross-perl binaries. Even then, the contents of
cross-config could end up in other packages just as easily.

To repeat:
> | summary 771496 If anything you are doing would fail after the
> removal of dpkg-cross, you're doing it wrong. It's going away,
> whether you want it to or not.

That does *not* apply to cross-config and the original bug made it
clear that the configuration elements could remain.

> Quoting Neil Williams in
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=771496#46:
> | summary 771496 If anything you are doing would fail after the
> removal of dpkg-cross, you're doing it wrong. It's going away,
> whether you want it to or not.

Wrong package for this bug report. The package you need for CMake and
other *configuration* support for cross-building (not *packaging*
support for cross-building) is cross-config.

https://packages.debian.org/sid/all/cross-config/filelist

/etc/dpkg-cross/cmake/CMakeCross.txt

That's the only file needed for CMake - it could just as easily be
migrated into another package.

> There is a reason why dpkg-cross is not part of jessie.
> 
> Wookey, should we add a blocker bug keep it out of jessie?

Holger: did you mean Stretch? If so, then instead of blocker bugs, what
we need is a new upload which only leaves the cross-config binary
package. But then I'm tired of this particular fight, that's why I
orphaned it.

However, Stretch must not release with the dpkg-cross and
libdebian-dpkgcross-perl binary packages. If the new upload doesn't
happen by the end of November 2017, then (as agreed at DebConf16), I'll
have to do it as a final QA upload, leaving only the cross-config
binary package.

-- 


Neil Williams
=============
http://www.linux.codehelp.co.uk/

Attachment: pgpgwgrR5EKnV.pgp
Description: OpenPGP digital signature

Reply via email to