Package: dislocker
Version: 0.6.1-6
Severity: important

Dear Maintainer,

When I run dislocker-find, it shows me the error:
$ sudo dislocker-find
/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot 
load such file -- libdislocker (LoadError)
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in 
        from /usr/bin/dislocker-find:26:in `<main>'

Apparently /usr/lib/ is missing. After libdislocker0-dev is 
installed, dislocker-find runs without any problem.
$ dpkg -S /usr/lib/
libdislocker0-dev: /usr/lib/

Either libdislocker0-dev has to be the required package for dislocker, like 
$ apt-cache show dislocker | grep Depends
Depends: libc6 (>= 2.3.6-6~), libdislocker0.6 (>= 0.6.1), libfuse2 (>= 2.6), 
libmbedcrypto0 (>= 2.0), libruby2.3 (>= 2.3.0~preview2), ruby

Or actually /usr/lib/ should be in the package libdislocker0.6.
If you need more info, please let me know.
My 2 cents.


-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 4.7.0-1-686-pae (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash
Init: systemd (via /run/systemd/system)

Versions of packages dislocker depends on:
ii  libc6            2.24-3
ii  libdislocker0.6  0.6.1-6
ii  libfuse2         2.9.7-1
ii  libmbedcrypto0   2.3.0-1
ii  libruby2.3       2.3.1-5+b1
ii  ruby             1:2.3.0+4

dislocker recommends no packages.

dislocker suggests no packages.

-- no debconf information

Reply via email to