Package: bash
Version: 4.4-1
Severity: important

Dear Maintainer,

*** Reporter, please consider answering these questions, where appropriate ***

   * What led up to the situation?

Tried to login on server or "su -" but got only 

-su: xmalloc: cannot allocate 800000008 bytes (1626112 bytes allocated)

so login isn't possible as root anymore. When running just "su" eg. bash not as 
login shell it first works. 

   * What exactly did you do (or not do) that was effective (or

1. Flushed .bash_history of user root - login works. But now no execution of 
any command is possible, ends with the xmalloc error.
2. run bash not as login-shell. Now all is working. 
3. tried as normal user. There is no problem.

   * What was the outcome of this action?

Root user may just use other shell like dash as login shell

   * What outcome did you expect instead?

Expect that root-user may use bash as login-shell

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.7.0-1-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages bash depends on:
ii  base-files   9.6
ii  dash         0.5.8-2.3
ii  debianutils  4.8
ii  libc6        2.24-3
ii  libtinfo5    6.0+20160917-1

Versions of packages bash recommends:
ii  bash-completion  1:2.1-4.3

Versions of packages bash suggests:
pn  bash-doc  <none>

-- no debconf information

Reply via email to