Source: python-debian
Version: 0.1.29
Severity: minor
Tags: patch

Hi,

I just installed python-debian via PyPI. It was missing the dependency
on the chardet module. Everything is fine in Debian, hence the minor
severity here.

Untested patch attached. I think it's right; I'm more used to using
requirements.txt.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-
diff --git a/setup.py b/setup.py
index 4cc7ebb..633f196 100644
--- a/setup.py
+++ b/setup.py
@@ -27,5 +27,5 @@ setup(name='python-debian',
       py_modules=['deb822'],
       maintainer='Debian python-debian Maintainers',
       maintainer_email='pkg-python-debian-ma...@lists.alioth.debian.org',
-      install_requires=['six'],
+      install_requires=['six', 'chardet'],
      )

Reply via email to