Ian Jackson writes ("Re: dgit-servers not yet updated?"):
> Package: dgit
> Version: 2.1
> Severity: important
> 
> Sean Whitton writes ("dgit-servers not yet updated?"):
> > Am I seeing the following because dgit-servers has not yet been updated
> > to 2.1?
> > 
> >     hephaestus ~/src/helm % dgit gbp-build
> >     Format `3.0 (quilt)', need to check/update patch stack
> >     dgit: quilt mode gbp requires split view so server needs to support
> >     dgit:  both "new" and "maint" tag formats, but config says it doesn't.
> 
> No, I think this is because the config supplied with dgit is wrong.

Indeed.  I didn't spot this because of course the test suite runs
against a private setup with its own config, and I didn't run a
separate ad-hoc test against the real infrastructure.  Sorry about
that.

Until a fixed package is available, this workaround helps:
  -cdgit-distro.debian.dgit-tag-format=old,new,maint
As in something like this:
  dgit -wgf -cdgit-distro.debian.dgit-tag-format=old,new,maint --quilt=gbp 
quilt-fixup

Thanks for the report.

Ian.

-- 
Ian Jackson <ijack...@chiark.greenend.org.uk>   These opinions are my own.

If I emailed you from an address @fyvzl.net or @evade.org.uk, that is
a private address which bypasses my fierce spamfilter.

Reply via email to