Package: gv
Version: 1:3.7.4-1
Severity: important

Dear Maintainer,

gv started having problems with PDF files after upgrading ghostscript
from version 9.06~dfsg-2+deb8u1 to 9.06~dfsg-2+deb8u3. When opening
a PDF file, gv shows a dialog window with the following message:

Execution of
gs -P- -dSAFER -dDELAYSAFER -dNODISPLAY -dQUIET -sPDFname=/tmp/policy.pdf 
-sDSCname=/tmp/gv_policy_pdf.mZ3b7u -c quit

At the same time, gv prints the following text on stdout:

Error: /invalidaccess in --.locksafe--
Operand stack:
   --dict:1170/1684(ro)(G)--   getenv   --nostringval--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--   
--nostringval--   false   1   %stopped_push   1910   1   3   %oparray_pop   
1909   1   3   %oparray_pop   1893   1   3   %oparray_pop   1787   1   3   
%oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --nostringval--   
--nostringval--   --nostringval--   2   %stopped_push   --nostringval--   1924  
 0   3   %oparray_pop   1923   0   3   %oparray_pop   --nostringval--
Dictionary stack:
   --dict:1170/1684(ro)(G)--   --dict:0/20(G)--   --dict:79/200(L)--
Current allocation mode is local
Current file position is 1899

gv is able to display the PDF file in spite of this error,
but the navigation controls are crippled. The file cannot
be scrolled backwards and the page list control is empty.

I suspect that this problem is an unintended side-effect
of fixing CVE-2013-5653 (see bug #839118).

Best regards,
 Wojciech Palacz

-- System Information:
Debian Release: 8.6
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.16.0-4-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gv depends on:
ii  ghostscript-x  9.06~dfsg-2+deb8u3
ii  libc6          2.19-18+deb8u6
ii  libx11-6       2:1.6.2-3
ii  libxinerama1   2:1.1.3-1+b1
ii  libxmu6        2:1.1.2-1
ii  libxt6         1:1.1.4-1+b1
ii  xaw3dg         1.5+E-18.2

Versions of packages gv recommends:
ii  xaw3dg  1.5+E-18.2

gv suggests no packages.

-- no debconf information

Reply via email to