Package: python-ironic-inspector-client
Version: 1.7.0-2
Severity: minor

When running any 'openstack xxx yyy' command, I'm getting

  WARNING: openstackclient.common.utils is deprecated and will be removed after 
Jun 2017. Please use osc_lib.utils

Trying to track this done, I see:

  # rgrep openstackclient.common /usr/{lib/python2.7/dist-packages,bin,sbin} | 
grep utils
  /usr/lib/python2.7/dist-packages/osc_lib-1.1.0.egg-info/PKG-INFO:        * 
openstackclient.common.utils -> osc_lib.utils
  Binary file /usr/lib/python2.7/dist-packages/openstackclient/common/utils.pyc 
openstackclient.common import utils

And the last file is in python-ironic-inspector-client...

According to #openstack-sdks, there is a newer version out.

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/16 CPU cores)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages python-ironic-inspector-client depends on:
ii  python-cliff            1.15.0-5
ii  python-keystoneclient   1:3.2.0-2
ii  python-openstackclient  3.2.0-2
ii  python-oslo.i18n        3.9.0-3
ii  python-oslo.utils       3.16.0-2
ii  python-pbr              1.10.0-1
ii  python-requests         2.11.1-1
ii  python-six              1.10.0-3
pn  python:any              <none>

python-ironic-inspector-client recommends no packages.

python-ironic-inspector-client suggests no packages.

-- no debconf information

Reply via email to