Package: conky-all
Version: 1.10.5-1
Severity: wishlist
Tags: patch

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Dear Maintainer,

Please build conky-all, and maybe some other builds, with PulseAudio
support enabled, which has been added in 1.10.3.

Best regards,

Kevin Velghe

- -- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (500, 'testing'), (200, 'stable'), (120, 'unstable'), (100, 
'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.7.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages conky-all depends on:
ii  libaudclient2     3.5~rc2-1
ii  libc6             2.24-3
ii  libcairo2         1.14.6-1+b1
ii  libcurl3-gnutls   7.50.1-1
ii  libdbus-glib-1-2  0.108-1
ii  libgcc1           1:6.2.0-6
ii  libglib2.0-0      2.50.1-1
ii  libimlib2         1.4.8-1
ii  libiw30           30~pre9-12
ii  liblua5.1-0       5.1.5-8.1+b1
ii  libncurses5       6.0+20160917-1
ii  libpulse0         9.0-4
ii  librsvg2-2        2.40.16-1
ii  libstdc++6        6.2.0-6
ii  libtinfo5         6.0+20160917-1
ii  libx11-6          2:1.6.3-1
ii  libxdamage1       1:1.1.4-2+b1
ii  libxext6          2:1.3.3-1
ii  libxfixes3        1:5.0.2-1
ii  libxft2           2.3.2-1
ii  libxinerama1      2:1.1.3-1+b1
ii  libxml2           2.9.4+dfsg1-2
ii  libxmmsclient6    0.8+dfsg-16+b2
ii  libxnvctrl0       340.93-1

conky-all recommends no packages.

Versions of packages conky-all suggests:
pn  apcupsd    <none>
pn  audacious  <none>
pn  moc        <none>
ii  mpd        0.19.19-1
pn  xmms2      <none>

- -- no debconf information

-----BEGIN PGP SIGNATURE-----

iQIuBAEBCgAYBQJYBh4lERxrZXZpbkBwYXJldGplLmJlAAoJELhLvPn7bRYLblIQ
AJV9qAYhPOHZaPqCI2fD3UgnnmbLNXMe2xGSalYd7l5LApox4oUc4k81ApcPYyzv
KahpNi5/EehRYU3d2GPpE8TZBRz3eMMhOwkbQazX6AwW9yIyJMUeosjqC0Z3WVhA
y/5h1daOvspFnkw9fVBbP3DxIWNfqDmaPpkolXV65C67R2wnXDG4tMPDIpX90TMD
QkshCfnteXbcTnZfksOk6QVhx/Sag/xNsWcdZMicLddbuU0VehRCA105vsRyoEe+
xrqqfQ0yIK5fo1e2fmM3Py8HWkkoQepdwwcxQYoodYjpvEfmkT5sVbMgCBFkvi06
wK4G5Y9RTukh3SXLYBbn09OzGAuMjdS7uQoFkAe1CW5f0xmNw35osPNO9ivEU1ym
R9CbPEgCMn6kPLZpl3vjmhJxuAimSKrPKBhBc7htmhMEkMt/iUWles06vYMHcl3h
tflcbAlsOUUUlA+iEhOqT/mH3rG83Y4mT8wF+vzETNa3PO8VwXU39OwMiVHVE9Yr
uXwQJD8Csi2jK8d7YT2BTubjPhtJyOArwCnA4i1XVH2Tnkk8dMtxEL1imOhmP040
5tGvJddS++r7bsICi2wXZsyJqyS3mE8STYH4JzdPPhOHIHK1QxH1bxEs/47lISeL
60jEF8ptq4dG+v+URGzcWA8hH4qxTV8uvkZxorOUMrf1
=PALy
-----END PGP SIGNATURE-----
>From a231bc420a7839cf365c7a6737f25eb0f2ff5097 Mon Sep 17 00:00:00 2001
From: Kevin Velghe <ke...@paretje.be>
Date: Sun, 16 Oct 2016 00:38:08 +0200
Subject: [PATCH] Enable pulseaudio

---
 debian/control | 5 +++--
 debian/rules   | 2 +-
 2 files changed, 4 insertions(+), 3 deletions(-)

diff --git a/debian/control b/debian/control
index 0b6daf9..3fbfd3c 100644
--- a/debian/control
+++ b/debian/control
@@ -34,6 +34,7 @@ Build-Depends:
  libxml2-dev,
  libxmmsclient-dev,
  libxnvctrl-dev [i386 amd64] | nvidia-settings [i386 amd64],
+ libpulse-dev,
  pkg-config (>= 0.19)
 Homepage: http://conky.sourceforge.net/
 Standards-Version: 3.9.8
@@ -139,7 +140,7 @@ Description: highly configurable system monitor (all features enabled)
  X11, XDamage, XDBE, Xft, MPD, MOC, math, hddtemp, portmon, RSS,
  Weather, wireless, IBM, nvidia, eve-online, Imlib2, ALSA mixer,
  apcupsd, I/O stats, argb, Lua and the cairo and imlib2 lua bindings,
- Audacious, and XMMS2.
+ Audacious, XMMS2, and PulseAudio.
 
 Package: conky-all-dbg
 Section: debug
@@ -158,7 +159,7 @@ Description: highly configurable system monitor (all features enabled - debug)
  X11, XDamage, XDBE, Xft, MPD, MOC, math, hddtemp, portmon, RSS,
  Weather, wireless, IBM, nvidia, eve-online, Imlib2, ALSA mixer,
  apcupsd, I/O stats, argb, Lua and the cairo and imlib2 lua bindings,
- Audacious, and XMMS2.
+ Audacious, XMMS2, and PulseAudio.
  .
  This package contains debugging symbols only.
 
diff --git a/debian/rules b/debian/rules
index 9a3e5d8..83cf3f9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -54,7 +54,7 @@ override_dh_auto_configure:
 	-DBUILD_XDBE=ON -DBUILD_CURL=ON -DBUILD_IMLIB2=ON -DBUILD_RSS=ON \
 	-DBUILD_WEATHER_METAR=ON -DBUILD_WEATHER_XOAP=ON -DBUILD_LUA_CAIRO=ON \
 	-DBUILD_LUA_IMLIB2=ON -DBUILD_LUA_RSVG=ON -DBUILD_AUDACIOUS=ON \
-	-DBUILD_XMMS2=ON -DBUILD_EVE=ON
+	-DBUILD_XMMS2=ON -DBUILD_EVE=ON -DBUILD_PULSEAUDIO=ON
 
 override_dh_auto_build:
 	dh_auto_build --builddirectory build-std
-- 
2.9.3

Reply via email to