On Tue, Oct 18, 2016 at 06:02:38PM +0000, Mattia Rizzolo wrote:
> > =================================== FAILURES 
> > ===================================
> > _______________________________ test_superblock 
> > ________________________________
> > 
> > differences = []
> > 
> >     @skip_unless_tool_is_older_than('unsquashfs', unsquashfs_version, '4.3')
> >     def test_superblock(differences):
> >         expected_diff = 
> > open(data('squashfs_superblock_expected_diff')).read()
> > >       assert differences[0].unified_diff == expected_diff
> > E       IndexError: list index out of range
> > 
> > tests/comparators/test_squashfs.py:59: IndexError
> > =========================== short test summary info 
> > ============================
> ...
> > SKIP [1] tests/comparators/test_squashfs.py:73: requires unsquashfs
> 
> so, it doesn't properly skip that test if unquashfs is not present,
> which is weird, since it's one thing we test in debci┬╣.
> 
> you said you're trying to build the released v61, not a git snapshot
> which happens to be a few commits after v61, right?

Correct, I see this test failure when building the v61 release from
PyPi.

Attachment: signature.asc
Description: PGP signature

Reply via email to