If this can be useful, I tried to enable this option by recompiling with apt-src:

apt-src  install jdupes
cd jdupes-1.6
***edit Makefile: uncomment "CFLAGS += -DENABLE_BTRFS"
cd ..
apt-src build jdupes
dpkg -i jdupes_1.6-1_amd64.deb

This _seems_ to work, as I can pass the -B option to jdupes, jdupes reports that some deduplication could be done ("finish with a Deduplication done (xxx files processed)"), but I obtain this kind of warnings (seems to be as many warnings as the number of files processed...): warning: dedupe only did 0 byes: ***file_x*** => ***file_y***: Invalid argument [-22]

I do not know how harmful may be these warnings, nor if the deduplication indeed worked at all... So probably a "test on your own risk" functionality for the moment.

Hoping that this report may help a correct btrfs deduplication by more knowledgeable people.

Raphaël


--
Raphaël Plasson, PhD
Maître de Conférences (Assistant Professor)

UMR 408 Université d'Avignon - INRA
Sécurité & Qualité des Produits d'Origine Végétale
Équipe 'Chimie des Antioxydants'

Université d'Avignon - UFR-ip STS
Campus Jean-Henri Fabre
301 rue Baruch de Spinoza BP 21239
84916 Avignon Cedex 9

Phone: +33(0)4 9014 4441
Cell phone: +33(0)6 8855 4223
email: raphael.plas...@univ-avignon.fr

Reply via email to