Hi Matthew,

have you tried using apt-get install -t jessie-backports python-certbot ?

On 1 December 2016 11:54:15 p.m. Matthew Gabeler-Lee <chee...@fastcat.org> wrote:

Package: python-certbot
Version: 0.9.3-1~bpo8+1
Severity: normal

Trying to install python-certbot (really letsencrypt), running into two
dependency issues, one with python-certbot itself and the other with an
indirect dependency python-acme has.

p-c depends on a newer version of python-cryptography than is available, and
depends on python-acme which depends on a newer version of python-openssl
than is available.

$ sudo apt install python-certbot python-acme
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-acme : Depends: python-openssl (>= 0.15) but 0.14-1 is to be installed
               Depends: python-cryptography (>= 0.8) but 0.6.1-1 is to be 
               Depends: python-setuptools (>= 11.3~) but 5.5.1-1 is to be 
               Recommends: python-dnspython but it is not going to be installed
python-certbot : Depends: python-cryptography (>= 0.7) but 0.6.1-1 is to be installed
                  Recommends: letsencrypt
                  Recommends: python-psutil (>= 2.2.1) but it is not going to 
be installed
E: Unable to correct problems, you have held broken packages.

-- System Information:
Debian Release: 8.6
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.8.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Reply via email to