Package: python3-pip
Version: 9.0.1-1
Severity: normal
Tags: upstream

Pip3 fails when attempting to list only outdated packages with pip3 list -o:


Exception:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/usr/lib/python3/dist-packages/pip/commands/list.py", line 157, in run
    packages = self.get_outdated(packages, options)
  File "/usr/lib/python3/dist-packages/pip/commands/list.py", line 168, in 
get_outdated
    dist for dist in self.iter_packages_latest_infos(packages, options)
  File "/usr/lib/python3/dist-packages/pip/commands/list.py", line 169, in 
<listcomp>
    if dist.latest_version > dist.parsed_version
TypeError: unorderable types: Version() > SetuptoolsVersion()


Similar options (-u/-e/..) seem unaffected and work as expected. Note that this 
is coming from my system Python 3, i.e. currently 3.5.2, on Stretch,
and only applies to pip3. Pip2 list -o doesn't fail. I'm using Debian's 
original pip3 package. Getting same result after reinstalling (pip), so I
don't think it's locally broken. Also might not even be an upstream problem, at 
least I'm not getting the error on other platforms, as far as I can say.

Gr.
Oliver


-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.8.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages python3-pip depends on:
ii  ca-certificates  20161102
ii  python-pip-whl   9.0.1-1
pn  python3:any      <none>

Versions of packages python3-pip recommends:
ii  build-essential     12.2
ii  python3-dev         3.5.1-4
ii  python3-setuptools  28.7.1-1
ii  python3-wheel       0.29.0-2

python3-pip suggests no packages.

Reply via email to