Package: mysql-server-5.7
Version: 5.7.16-2
Severity: important

I have mysql not on boot-up and also if the service is running i get this
error everytime there is a
new package of mysql and it's impossible to update the package itself.
Configurazione di mysql-server-5.7 (5.7.16-2)...
insserv: warning: current start runlevel(s) (empty) of script `mysql'
overrides LSB defaults (2 3 4
5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script
`mysql' overrides LSB defaults
(0 1 6).
mysql_upgrade: Got error: 2002: Can't connect to local MySQL server through
socket
'/var/run/mysqld/mysqld.sock' (2) while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11


-- System Information:
Distributor ID:    Ubuntu
Description:    Ubuntu, and definitely not Arch Linux
Release:    rolling
Codename:    sid
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.9.2-towo.2-siduction-amd64 (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8) (ignored:
LC_ALL set to it_IT.UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages mysql-server-5.7 depends on:
ii  adduser                3.115
ii  bsdutils               1:2.29-1
ii  debconf [debconf-2.0]  1.5.59
ii  init-system-helpers    1.46
ii  libatomic1             6.3.0-2
ii  libc6                  2.24-8
ii  libevent-core-2.0-5    2.0.21-stable-2.1
ii  libgcc1                1:6.3.0-2
ii  liblz4-1               0.0~r131-2
ii  libmecab2              0.996-3
ii  libstdc++6             6.3.0-2
ii  lsb-base               9.20161125
ii  mysql-client-5.7       5.7.16-2
ii  mysql-common           5.8+1.0.1
ii  mysql-server-core-5.7  5.7.16-2
ii  passwd                 1:4.4-1
ii  perl                   5.24.1~rc4-1
ii  psmisc                 22.21-2.1+b1
ii  zlib1g                 1:1.2.8.dfsg-4

Versions of packages mysql-server-5.7 recommends:
pn  libhtml-template-perl  <none>

Versions of packages mysql-server-5.7 suggests:
pn  mailx   <none>
pn  tinyca  <none>

-- debconf information:
  mysql-server/password_mismatch:
  mysql-server/no_upgrade_when_using_ndb:
  mysql-server-5.7/start_on_boot: true
  mysql-server-5.7/really_downgrade: false
  mysql-server-5.7/postrm_remove_databases: false
  mysql-server-5.7/nis_warning:

Reply via email to