Mattia Rizzolo:
> Package: diffoscope
> Version: 77
> Severity: important
> So, yesterday we tried to re-enable artifacts saving on jenkins, and the
> disc filled again because of GBs of temporary files left around.
> In a log the only message I see is:
> |Wed Feb 15 23:28:21 UTC 2017  I: diffoscope 77 will be used to compare the 
> two builds:
> |E: Caught signal ‘Terminated’
> |Thu Feb 16 03:30:35 UTC 2017  E: otb failed to build reproducibly in 
> experimental on i386.
> I have yet to try to reproduce it this time (and weird, because in when
> I tried before reenabling the saving artifacts it did clean up for me).
> [..]

Where did you do this? On the page for otb on in the rbuild.log I 

Mon Jan 23 04:11:07 UTC 2017  I: diffoscope 69 will be used to compare the two 
E: Caught signal ‘Terminated’: terminating immediately
E: Caught signal ‘Terminated’
Mon Jan 23 06:11:14 UTC 2017  E: otb failed to build reproducibly in unstable 
on amd64.

This possibly means diffoscope got a second SIGTERM whilst it was trying to 
clean up the first one. But this isn't present in your example above.

WARNING: You shouldn't trust packages downloaded from this host, they can 
contain malware or the worst of your fears, packaged nicely in debian format.
If you are aware of this and just want to use these artifacts to investigate 
why diffoscope 69 had issues, you can download the artifacts from the following 

I tried to download this URL but it looks like it's been deleted already. :(


GPG: ed25519/56034877E1F87C35
GPG: rsa4096/1318EFAC5FBBDBCE

Reply via email to