On Mon, May 15, 2017 at 8:34 PM, Niels Thykier <[email protected]> wrote:
> Michael Stapelberg: > > On Mon, Apr 10, 2017 at 12:55 PM, Niels Thykier <[email protected]> > wrote: > > > >> On Wed, 22 Mar 2017 19:01:54 +0100 Michael Stapelberg > >> <[email protected]> wrote: > >>> Package: debhelper > >>> Version: 10.2.5 > >>> Severity: normal > >>> > >>> Currently, when trying to build a Debian package whose binary packages > >>> specify “€œArchitecture: arm64“€ on an amd64 machine, I get the > >> following > >>> error message: > >>> > >>> raspi3-firmware $ dh clean > >>> dh: No packages to build. > >>> > >>> While this is technically correct, the error message could be way > >>> friendlier: I’€™d suggest something along the lines of “No packages to > >>> build (architecture mismatch: got amd64, want arm64)“€ . > >>> > >>> What do you think? > >>> > >>> [...] > >> > >> I am fine with getting patches for the better error messages. > >> > > > > Perfect. Find attached a patch to that effect. > > > > > > Thanks, > > I am not sure that it is safe to change the return value of > package_arch(). E.g. it is used to determine the name of the binNMU > changelog, and I suspect things will break if all binNMUs start to use > "changelog.Debian.linux-any.gz" regardless architecture. :) > Thanks for the details. I found 4 callers of package_arch, of which 2 merely compare whether package_arch returns 'all'. I think it would be cleaner to move the “turn specified arch into actual build arch” logic into the remaining 2 callsites, rather than keep the old misnomer package_arch around. Do you agree? If not, what do you suggest we do? > > >> > >> Please keep in mind that the "want" part includes architecture > >> wildcards, which debhelper doesn't deal with directly so far. > >> > > > > I don’t follow. My patch displays the “want” part as-is. Shouldn’t that > > give users all the information they need? > > > > [...] > > Right, it will show wildcards and that is what you intended. :) I agree > it is better than the status quo, so lets go with that. > > Thanks, > ~Niels > > > -- Best regards, Michael

