Hi Arnaud.

On Mon, 5 Jun 2017 22:35:01 +0700 Arnaud <elboulang...@gmail.com>
wrote:

> Done, the watch file seem to work according to `uscan`, but
mentors.debian.net says there's a problem. I'm not sure what's wrong.

Take a look on [1] as an example, your `watch` file is broken
presumably since you're calling `uupdate` directly.

[1]https://wiki.debian.org/debian/watch#GitHub

> al@think:~/debian/pnmixer-0.7.2$ uscan -dd -v
> uscan info: uscan (version 2.17.6+deb9u1) See uscan(1) for help
> uscan info: Scan watch files in .
> uscan info: Check debian/watch and debian/changelog in .
> uscan info: package="pnmixer" version="0.7.2-1" (as seen in
> debian/changelog)
> uscan info: package="pnmixer" version="0.7.2" (no epoch/revision)
> uscan info: ./debian/changelog sets package="pnmixer" version="0.7.2"
> uscan info: Process ./debian/watch (package=pnmixer version=0.7.2)
> uscan info: opts: uversionmangle=s/-
> rc/~rc/,filenamemangle=s%(?:.*?)?v?(\d[\d.]*)\.tar\.gz%<project>-
> $1.tar.gz%
> uscan info: line: https://github.com/nicklan/pnmixer/tags
> (?:.*?/)?v?(\d[\d.]*)\.tar\.gz debian uupdate
> uscan info: Parsing uversionmangle=s/-rc/~rc/
> uscan info: Parsing
> filenamemangle=s%(?:.*?)?v?(\d[\d.]*)\.tar\.gz%<project>-$1.tar.gz%
> uscan info: line: https://github.com/nicklan/pnmixer/tags
> (?:.*?/)?v?(\d[\d.]*)\.tar\.gz debian uupdate
> uscan info: Last orig.tar.* tarball version (from debian/changelog):
> 0.7.2
> uscan info: Last orig.tar.* tarball version (dversionmangled): 0.7.2
> uscan info: Requesting URL:
>    https://github.com/nicklan/pnmixer/tags
> uscan info: Matching pattern:
>    (?:(?:https://github.com)?\/nicklan\/pnmixer\/tags)?(?:.*?/)?v?(\d
> [\d.]*)\.tar\.gz
> uscan info: Found the following matching hrefs on the web page
> (newest first):
>    /nicklan/pnmixer/archive/v0.7.2.tar.gz (0.7.2) index=0.7.2-1 
>    /nicklan/pnmixer/archive/v0.7.1.tar.gz (0.7.1) index=0.7.1-1 
>    /nicklan/pnmixer/archive/v0.7.tar.gz (0.7) index=0.7-1 
>    /nicklan/pnmixer/archive/v0.6.1.tar.gz (0.6.1) index=0.6.1-1 
>    /nicklan/pnmixer/archive/v0.6.tar.gz (0.6) index=0.6-1 
> uscan info: Matching target for downloadurlmangle: https://github.com
> /nicklan/pnmixer/archive/v0.7.2.tar.gz
> uscan info: Upstream URL (downloadurlmangled):
>    https://github.com/nicklan/pnmixer/archive/v0.7.2.tar.gz
> uscan info: Newest upstream tarball version selected for download
> (uversionmangled): 0.7.2
> uscan info: Matching target for filenamemangle:
> /nicklan/pnmixer/archive/v0.7.2.tar.gz
> uscan info: Download filename (filenamemangled): <project>-
> 0.7.2.tar.gz
> uscan info: Newest version of pnmixer on remote site is 0.7.2, local
> version is 0.7.2
> uscan info:    => Package is up to date for from
>       https://github.com/nicklan/pnmixer/archive/v0.7.2.tar.gz
> uscan info:    => Forcing download as requested
> uscan info: Not downloading, using existing file: <project>-
> 0.7.2.tar.gz
> uscan info: Start checking for common possible upstream OpenPGP
> signature files
> uscan info: End checking for common possible upstream OpenPGP
> signature files
> uscan info: Missing OpenPGP signature.
> uscan info: New orig.tar.* tarball version (oversionmangled): 0.7.2
> uscan info: Executing internal command:
>    mk-origtargz --package pnmixer --version 0.7.2 --compression gzip
> --directory .. --copyright-file debian/copyright ../<project>-
> 0.7.2.tar.gz
> uscan info: New orig.tar.* tarball version (after mk-origtargz):
> 0.7.2
> uscan info: Successfully symlinked ../<project>-0.7.2.tar.gz to
> ../pnmixer_0.7.2.orig.tar.gz.
> uscan die: uscan: Failed to Execute user specified script:
>    uupdate -f --verbose --upstream-version 0.7.2
> uupdate: PACKAGE     = "pnmixer" is in the top of debian/changelog
> uupdate: VERSION     = "0.7.2-1" is in the top of debian/changelog
> uupdate: EPOCH       = "" is epoch part of $VERSION
> uupdate: SVERSION    = "0.7.2-1" is w/o-epoch part of $VERSION
> uupdate: UVERSION    = "0.7.2" the upstream portion w/o-epoch of
> $VERSION
> uupdate: Old: <epoch:><version>-<revision> = 0.7.2-1
> uupdate: Old: <epoch:>                     = 
> uupdate: Old:         <version>-<revision> = 0.7.2-1
> uupdate: Old:         <version>            = 0.7.2
> uupdate: New:         <version>            = 0.7.2
> uupdate: You can not execute this from ../pnmixer-0.7.2/.

Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to