Package: squid
Severity: normal

Dear Maintainer,

All current squid packages (specifically from jessie onward) are packaged with
initscripts (/etc/init.d/squid) instead of a systemd service. Upstream squid has
been packaged with a squid.service file since version 3.5.1.

The reason this is an issue for me is that my company is running squid as a 
transparent
proxy for all outbound internet traffic in our production environments. Because
of some AWS limitations, we only have one per availability zone. This leaves us
in a bad situation should the squid process fail.

Because of some limitations of our provisioning and bootstrapping setup, we are
unable to just add a respawn argument to our inittab file without either manual
intervention, or completely restructuring how we deploy services. It would be
substantially easier for us to manage a systemd service file.

This is non-critical, and we can package our own version of squid that uses the
systemd service, but it would be nice if upstream squid also included it.

Thanks,
Don Kuntz


-- System Information:
Debian Release: 9.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-3-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages squid depends on:
ii  adduser                  3.115
ii  libc6                    2.24-11+deb9u1
ii  libcap2                  1:2.25-1
ii  libcomerr2               1.43.4-2
ii  libdb5.3                 5.3.28-12+b1
pn  libdbi-perl              <none>
pn  libecap3                 <none>
ii  libexpat1                2.2.0-2
ii  libgcc1                  1:6.3.0-18
ii  libgssapi-krb5-2         1.15-1
ii  libkrb5-3                1.15-1
ii  libldap-2.4-2            2.4.44+dfsg-5
pn  libltdl7                 <none>
ii  libnetfilter-conntrack3  1.0.6-2
ii  libnettle6               3.3-1+b1
ii  libpam0g                 1.1.8-3.6
ii  libsasl2-2               2.1.27~101-g0780600+dfsg-3
ii  libstdc++6               6.3.0-18
ii  libxml2                  2.9.4+dfsg1-2.2
ii  logrotate                3.11.0-0.1
ii  lsb-base                 9.20161125
ii  netbase                  5.4
pn  squid-common             <none>

Versions of packages squid recommends:
pn  libcap2-bin  <none>

Versions of packages squid suggests:
pn  resolvconf   <none>
pn  smbclient    <none>
pn  squid-cgi    <none>
pn  squid-purge  <none>
pn  squidclient  <none>
pn  ufw          <none>
pn  winbindd     <none>

Reply via email to