Thanks for the quick response.

>>   FATAL ERROR:>>   Both /lib/x86_64-linux-gnu/ and 
>> /usr/lib/x86_64-linux-gnu/ exist.
> This is weird, because I see nothing in the package which would create 
> this link.

I don't think that was due to usrmerge, I think it was related to me having both
libpng12-0 and libpng16-16 installed (?). usrmerge only gets the blame for 
everything that happened afterwards. :)

> You can boot from a live CD and chroot or add init=/bin/bash to the > kernel 
> command line. Then fix the libpng thing and keep running usrmerge 
> until it complets.

Thanks for the hint. Adding init=/bin/bash (and changing a ro to rw) worked.
I still had some problems to resolve after that:

1. I could not trivially run convert-usrmerge again. It failed because perl 
could not find LD_LIBRARY_PATH worked for that. The script 
completed, but reported a number of broken links.

2. On reboot, /sbin/init failed and the system panicked.
ldd /usr/sbin/init revealed a number of missing libraries, eg
The issue was the same in every case. In /usr/lib/x86_64-linux-gnu, was a circular symlink pointing to 
There was a link pointing to, which 
was correct. So basically I had to rename all the *usrmerge-broken links.

The full list of affected items was:

After fixing all these, the system seems ok again.

Reply via email to