severity 871446 wishlist

Hi Aaron,

On Mon, Aug 07, 2017 at 10:25:13PM -0400, Aaron M. Ucko wrote:
> Thanks for taking care of #828871!  jemalloc now compiles on
> hurd-i386, but the build still ultimately fails because the
> aligned_alloc test hangs (hard):

I spent a lot of time at DebCamp trying to debug this on exodar before
uploading and it was failing with the same symptom. The test hanged to
the point where neither Ctrl+C nor Ctrl+\ worked, while the session
remained open. I tried logging in from another terminal, ran "ps" and
that kept hanging as well(!), with no output.

In the end, I thought it was some odd kernel behavior of the porterbox
and uploaded the package, in the hope that it would work on the buildd.
Turns out that it didn't :(

I'm pretty clueless about Hurd and over my head, so I'm afraid there's
not much more I can do, especially when my debugging is hindered by the
fact that not even most basic tools (like ps) aren't working...

Note that I'm staging 5.0.1 for experimental and tried to build that on
Hurd too, but that FTBFSes for another reason: Hurd is missing
pthread_getaffinity_np. I tried replacing that by sched_getaffinity (a
noop on Hurd, apparently) but that build failed the test suite, for a
seemingly different reason.

In general, jemalloc is (copying from the package description): "a
library providing a malloc(3) implementation for multi-threaded
processes on multi-processor systems". Given that Hurd right now doesn't
even support SMP, I wonder if there is even much point in going deep
down that rabbithole in an attempt to fix all of those issues.

I certainly don't have the knowledge or the bandwidth to do so, but if
you folks disagree and manage to make it work, I wouldn't mind carrying
(or even forwarding upstream) such patches.


Reply via email to