Hi!

On 2016-08-09 at 04:48 (+0300), Dark Penguin wrote:
> This is one of two bugs with Remmina that really annoy me; after a
> while, I've gathered more data and now I think have the simplest way
> to reproduce the problem. Also, this time all the machines are running
> Debian Jessie with MATE.
>
> - I connect over VNC to one machine with a 1024x768 screen. A small
> window appears in the center of my FullHD screen. (This is a good
> starting point to see all kinds of scaling problems that I have.)
>
> - Then I connect to another machine with a FullHD screen. The window
> is still the same size, but now a FullHD screen is cramped into it
> (without honoring my "Maintain scale ratio" option, of course.)
>
> Now if I resize the window by dragging its border, or click "Maintain
> scale ratio" twice to disable it and enable it back, then it resizes
> the image properly; but whatever else I do, the scale ration is not
> honored.
>
> What I've tried:
>
> - Being not happy, I try to "Maximize" the window. The image is now
> stretched in a thin horizontal line with black borders above and below
> - 
> neither honoring the scale ratio, nor even scaling to fit all the screen.
>
> - If I click "Resize the windows to fit in remote resolution", the
> same happens.
>
> - If I click "Toggle fullscreen mode", the same happens.
>
> - After any of those, if I toggle the "Scaling mode" off and back on,
> then it scales to cover all the window, but still does not honor the
> "Maintain scale ratio".
>
>
> I've also tried this with RDP - connecting to Windows machines. The
> results are the same.
>
> And finally, only in the case when the remote screen is SMALLER than
> the window, turning "Scaled mode" off and on helps resize the window
> properly. When the remote screen is LARGER than the window, it does
> not honor the aspect ratio.

Could you please check if the problem persists with 1.2.0-rcgit.20-1 in
experimental suite?

Thanks.

-- 
Matteo F. Vescovi

Attachment: signature.asc
Description: PGP signature

Reply via email to