found 840943 2.17.10
thanks

On Sun, 16 Oct 2016 13:46:14 +0200 Robert Luberda <rob...@debian.org> wrote:
>
> Hi
>
> With the following watch file for my rlinetd package
>
> # control file for the uscan(1) tool
> version=4
> opts="pgpmode=next" http://alioth.debian.org/frs/?group_id=30928 \
> (?:.*)/@PACKAGE@@ANY_VERSION@@ARCHIVE_EXT@ debian
> opts="pgpmode=previous" http://alioth.debian.org/frs/?group_id=30928 \
> (?:.*)/@PACKAGE@@ANY_VERSION@@SIGNATURE_EXT@ previous
>
>
> uscan --verbose shows this:
>
> [ stripped some output ]
> uscan info: Matching target for downloadurlmangle:
> http://alioth.debian.org/frs/download.php/file/3966/rlinetd-0.9.tar.gz
> uscan info: Upstream URL (downloadurlmangled):
> http://alioth.debian.org/frs/download.php/file/3966/rlinetd-0.9.tar.gz
> uscan info: Newest upstream tarball version selected for download
> (uversionmangled): 0.9
> uscan info: Download filename (filenamemangled): rlinetd-0.9.tar.gz
> uscan info: Newest version of rlinetd on remote site is 0.9, local
> version is 0.9
> uscan info: => Package is up to date for from
> http://alioth.debian.org/frs/download.php/file/3966/rlinetd-0.9.tar.gz
> uscan info: opts: pgpmode=previous
> uscan info: line: http://alioth.debian.org/frs/?group_id=30928
> (?:.*)/rlinetd[-_]?(\d[\-+\.:\~\da-zA-Z]*)(?i)\.(?:tar\.xz|tar\.bz2|tar\.gz|zip)\.(?:asc|pgp|gpg|sig)
> previous
> uscan info: Parsing pgpmode=previous
> uscan info: line: http://alioth.debian.org/frs/?group_id=30928
> (?:.*)/rlinetd[-_]?(\d[\-+\.:\~\da-zA-Z]*)(?i)\.(?:tar\.xz|tar\.bz2|tar\.gz|zip)\.(?:asc|pgp|gpg|sig)
> previous
> uscan info: Last orig.tar.* tarball version (from debian/changelog):
> uscan warn: Unable to set versionmode=prev for the line without opts=pgpmode=prev
> in debian/watch, skipping:
> http://alioth.debian.org/frs/?group_id=30928
> (?:.*)/rlinetd[-_]?(\d[\-+\.:\~\da-zA-Z]*)(?i)\.(?:tar\.xz|tar\.bz2|tar\.gz|zip)\.(?:asc|pgp|gpg|sig) previous
> uscan info: Scan finished
>
>
> The `Unable to set versionmode=prev for the line without opts=pgpmode=prev' > warning is really confusing, as it does not really says what is wrong, and
> what I as a user can do to get rid of it. Not to mention that it
> suggests replacing `pgpmode=previous' (taken from the man page) with
> `pgpmode=prev' in the watch file...
>
> It took me some time to discover that the warning really means that the
> locally downloaded version is just the same as the latest remote version...


This doesn't seems fixed in 2.17.10

I now get:

Use of uninitialized value $lastversion in concatenation (.) or string at /usr/bin/uscan line 2738, <WATCH> line 7. uscan warn: Unable to set versionmode=prev for the line without opts=pgpmode=prev
  in debian/watch, skipping:
  https://red.libssh.org/projects/libssh/files /attachments/download/(?:\d+)/libssh-[-_]?(\d[\-+\.:\~\da-zA-Z]*).tar.asc previous

There is an extra perl error here

(and the missmatch between pgpmode=prev and pgpmode=previous is still here)

Reply via email to