László Böszörményi (GCS) wrote:
> On Thu, Feb 1, 2018 at 3:45 PM, Yavor Doganov <ya...@gnu.org> wrote:
> > That would have been with versions before 59.1-1.  The configure run
> > fails because the icu-config script has been removed.  You have to
> > pass --disable-icu-config to build gnustep-base.

> Exactly, I did that and it built with ICU 60.2-3. Yesterday when I
> tried to build again the same gnustep-base source (I still have it
> as a local NMU with the disabled icu-config) the mentioned test
> failed.  Hence I think it's not ICU itself which changes the
> 'negativeFormat'.  I've the buildinfo file from the previous
> successful compilation and will check what's changed.

Hmm, have you by any chance performed the previous (successful) build
in a UTF-8 locale?  It's not convenient for me to test at the moment,
but I think the non-breaking space is discarded in a proper locale
while it is retained in the C locale, which could explain the failure.

Reply via email to