Package: wicd
Version: 1.7.4+tb2-5
Severity: normal

I have two APs with the same name, to cover a wide area. These appear
differently as different "networks" in the wicd GTK UI. They both
require indivdual configuration, individual settings, and so on thus
making them appear to be independent.

But yet, clicking "connect" on one of them will quite often actually
pick whichever one is the closer stronger signal, regardless of which of
the two whose button I clicked on.

wicd needs to make up its mind clearly about what the deal is with
multiple APs having the same name. Are they part of the same "network",
or not?

 * If they are, I'd expect to see them just once in the list, having to
   configure password and other settings just once, and generally not
   even have to think about the fact I have two APs,

or

 * If they are to be separate, then the "connect" button really ought to
   connect to the one I actually asked for.

Thanks,

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.14.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_GB:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages wicd depends on:
ii  wicd-cli [wicd-client]  1.7.4+tb2-5
ii  wicd-daemon             1.7.4+tb2-5
ii  wicd-gtk [wicd-client]  1.7.4+tb2-5

wicd recommends no packages.

wicd suggests no packages.

Versions of packages wicd-cli depends on:
ii  python       2.7.14-4
ii  wicd-daemon  1.7.4+tb2-5

Versions of packages wicd-cli recommends:
ii  sudo  1.8.21p2-3

Versions of packages wicd-gtk depends on:
ii  python         2.7.14-4
ii  python-glade2  2.24.0-5.1+b1
ii  python-gtk2    2.24.0-5.1+b1
ii  wicd-daemon    1.7.4+tb2-5

Versions of packages wicd-gtk recommends:
ii  gksu           2.0.2-9+b1
ii  python-notify  0.1.1-4

Versions of packages wicd-daemon depends on:
ii  adduser          3.116
ii  dbus             1.12.2-1
ii  debconf          1.5.65
ii  iputils-ping     3:20161105-1
ii  isc-dhcp-client  4.3.5-3+b2
ii  lsb-base         9.20170808
ii  psmisc           23.1-1
ii  python           2.7.14-4
ii  python-dbus      1.2.4-1+b4
ii  python-gobject   3.26.1-2
ii  python-wicd      1.7.4+tb2-5
ii  wireless-tools   30~pre9-12+b1
ii  wpasupplicant    2:2.6-15

Versions of packages wicd-daemon recommends:
ii  rfkill                  0.5-3
ii  wicd-cli [wicd-client]  1.7.4+tb2-5
ii  wicd-gtk [wicd-client]  1.7.4+tb2-5

Versions of packages wicd-daemon suggests:
ii  pm-utils  1.4.1-17

Versions of packages python-wicd depends on:
ii  net-tools  1.60+git20161116.90da8a0-1
ii  python     2.7.14-4

Versions of packages python-wicd suggests:
pn  ethtool   <none>
ii  iproute2  4.14.1-1

-- debconf information:
* wicd/users:


-- 
Paul "LeoNerd" Evans

leon...@leonerd.org.uk      |  https://metacpan.org/author/PEVANS
http://www.leonerd.org.uk/  |  https://www.tindie.com/stores/leonerd/

Reply via email to