Package: duplicity
Version: 0.7.16-1
Followup-For: Bug #890645

The command "pip install b2" does seem to work, although I haven't done 
exhaustive testing.

I ran the following commands (as root):

apt install python-arrow python-requests python-six python-tqdm python-dateutil 
python-funcsigs python-concurrent.futures
pip install b2

And then tried a duplicity --collection-status (also as root) which worked.

Note: I used apt to install the depencies for b2 which were in the repository.
Alternatively, maybe those should bacomee dependencies of duplicity?

Of course, the comments that I suggested putting in the README should probably
go in a News entry, as you had suggested.

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (900, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.14.0-3-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_IE.utf8, LC_CTYPE=en_IE.utf8 (charmap=UTF-8) (ignored: LC_ALL 
set to en_IE.utf8), LANGUAGE=en_IE.utf8 (charmap=UTF-8) (ignored: LC_ALL set to 
Shell: /bin/sh linked to /bin/bash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages duplicity depends on:
ii  gnupg             2.2.4-3
ii  libc6             2.26-6
ii  librsync1         0.9.7-10+b1
ii  python            2.7.14-4
ii  python-fasteners  0.12.0-3
ii  python-lockfile   1:0.12.2-2

Versions of packages duplicity recommends:
ii  python-oauthlib  2.0.6-1
ii  python-paramiko  2.0.0-1
ii  python-pexpect   4.2.1-1
ii  python-urllib3   1.22-1
ii  rsync            3.1.2-2.1

Versions of packages duplicity suggests:
ii  lftp                4.8.1-1
pn  ncftp               <none>
ii  python-boto         2.44.0-1
pn  python-cloudfiles   <none>
pn  python-gdata        <none>
pn  python-swiftclient  <none>
pn  tahoe-lafs          <none>

-- no debconf information

Reply via email to