I just reported a bug but now realized this is the same one.
Please dup/close the new bug appearing any minute as you want.
(copy my update here)

Default Dependencies will cause dependency loop.
Here a full analysis and suggestion ...

I've also got reported issues which looked like a failed to start service
on boot with:
   Active: failed (Result: resources)

A restart on the system after boot worked.

The actual issue was eventually to be found as: "Read-only file system".
After a while I realized we essentially hit [1].

Since [2] the service sets DefaultDependencies=no
But OTOH we use "PrivateTmp=yes" which needs writable /var/tmp.

The combination of the above without precaution is the issue as it may
be started before all file systems are up.

I propose a change to the dependencies that in all my tests worked fine with:
1. still being before cloud-init
2. the file system being ready and no more hitting the issue

--- a/debian/open-vm-tools.service
+++ b/debian/open-vm-tools.service
@@ -4,6 +4,7 @@ Documentation=http://open-vm-tools.sourceforge.net/about.php


[2]: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=859677

Christian Ehrhardt
Software Engineer, Ubuntu Server
Canonical Ltd

Reply via email to