Package: kmix
Version: 4:17.12.2-1
Severity: important


the latest update of kmix in unstable didn't correctly install the desktop 
files for autostarting and restoring volumes.

It seems that when the old kmix package is removed the links from /etc/xdg/
autostart/restore_kmix_volumes.desktop to /usr/share/autostart/
kmix_autostart.desktop aren't removed. (Respectively for 
restore_kmix_volumes.desktop). Therefore the config files, which seem to have 
moved to etc now, are placed as dpkg-new and the old links are left dangling.

The fix should be checking for those old links in the preinst script and 
removing them before installing the new package.

Best regards

-- System Information:
Debian Release: buster/sid
  APT prefers oldstable-proposed-updates
  APT policy: (500, 'oldstable-proposed-updates'), (500, 'unstable'), (1, 
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.15.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8), LANGUAGE= 
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages kmix depends on:
ii  libasound2               1.1.3-5
ii  libc6                    2.26-6
ii  libcanberra0             0.30-6
ii  libkf5configcore5        5.42.0-2
ii  libkf5configgui5         5.42.0-2
ii  libkf5configwidgets5     5.42.0-2
ii  libkf5coreaddons5        5.42.0-2
ii  libkf5dbusaddons5        5.42.0-2
ii  libkf5globalaccel5       5.42.0-2
ii  libkf5i18n5              5.42.0-2
ii  libkf5iconthemes5        5.42.0-2
ii  libkf5notifications5     5.42.0-2
ii  libkf5plasma5            5.42.0-3
ii  libkf5widgetsaddons5     5.42.1-2
ii  libkf5windowsystem5      5.42.0-2
ii  libkf5xmlgui5            5.42.0-2
ii  libpulse-mainloop-glib0  11.1-4
ii  libpulse0                11.1-4
ii  libqt5core5a             5.9.2+dfsg-12
ii  libqt5dbus5              5.9.2+dfsg-12
ii  libqt5gui5               5.9.2+dfsg-12
ii  libqt5widgets5           5.9.2+dfsg-12
ii  libqt5xml5               5.9.2+dfsg-12
ii  libstdc++6               8-20180218-1

kmix recommends no packages.

kmix suggests no packages.

-- no debconf information

Reply via email to