Package: lxc
Version: 1:2.0.7-2+deb9u1
Severity: important

Stretch's lxc fails to create a -t debian -- -r sid container, because
it doesn't find the iproute package, not longer included in unstable:

…
I: Checking component main on http://httpredir.debian.org/debian...
E: Couldn't find these debs: iproute
Failed to download the rootfs, aborting.
Failed to download 'debian base'
failed to install debian
lxc-create: lxccontainer.c: create_run_template: 1297 container creation 
template for sid failed
lxc-create: tools/lxc_create.c: main: 318 Error creating container sid

Changing iproute for iproute2 in /usr/share/lxc/templates/lxc-debian
solves the issue.

Thanks for your work packaging lxc,

Santiago

-- System Information:
Debian Release: 9.3
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: armhf (armv7l)

Kernel: Linux 4.9.0-5-armmp-lpae (SMP w/2 CPU cores)
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE=C.UTF-8 
(charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages lxc depends on:
ii  init-system-helpers  1.48
ii  libapparmor1         2.11.0-3
ii  libc6                2.24-11+deb9u1
ii  libcap2              1:2.25-1
ii  libgnutls30          3.5.8-5+deb9u3
ii  liblxc1              1:2.0.7-2+deb9u1
ii  libseccomp2          2.3.1-2.1
ii  libselinux1          2.6-3+b3
ii  lsb-base             9.20161125
ii  python3              3.5.3-1
ii  python3-lxc          1:2.0.7-2+deb9u1

Versions of packages lxc recommends:
ii  bridge-utils  1.5-13+deb9u1
ii  debootstrap   1.0.89
ii  dirmngr       2.1.18-8~deb9u1
ii  dnsmasq-base  2.76-5+deb9u1
ii  gnupg         2.1.18-8~deb9u1
ii  iptables      1.6.0+snapshot20161117-6
ii  libpam-cgfs   2.0.7-1
ii  lxcfs         2.0.7-1
ii  openssl       1.1.0f-3+deb9u1
ii  rsync         3.1.2-1+deb9u1
ii  uidmap        1:4.4-4.1

Versions of packages lxc suggests:
pn  apparmor     <none>
pn  btrfs-tools  <none>
pn  lvm2         <none>

-- Configuration Files:
/etc/lxc/default.conf changed:
lxc.network.type = veth
lxc.network.link = lxcbr0
lxc.network.flags = up
lxc.network.hwaddr = 00:16:3e:xx:xx:xx


-- no debconf information

Reply via email to