Package: src:libkf5ksieve
Version: 4:16.04.3-2
Severity: important
Tags: patch, stretch

--- Please enter the report below this line. ---

kmail in stretch only supports TLSv1.0 which hinders it to connect to mail 
servers that only support TLSv1.2 or TLSv.1.1.

The attached patch is a backport of the upstream fix from here:

It is necessary for sieve connections.

I primary reported the patches here
but was told on irc to file separate bug reports.

I tested this patch for some weeks on my system without any issues.
Pleas let me know if you have any questions.

Thank you for maintaining KDE packages in Debian!

--- System information. ---
Kernel:       Linux 4.9.0-6-amd64

Debian Release: 9.3
  500 stable-updates 
  500 stable 
  100 stretch-backports 

--- Package information. ---
Package's Depends field is empty.

Package's Recommends field is empty.

Package's Suggests field is empty.

--- a/src/kmanagesieve/sessionthread.cpp
+++ b/src/kmanagesieve/sessionthread.cpp
@@ -453,7 +453,7 @@
         m_sslCheck->setInterval(60 * 1000);
         connect(m_sslCheck, &QTimer::timeout, this, &SessionThread::slotSslTimeout);
-    m_socket->setAdvertisedSslVersion(KTcpSocket::TlsV1);
+    m_socket->setAdvertisedSslVersion(KTcpSocket::SecureProtocols);
     connect(m_socket, &KTcpSocket::encrypted, this, &SessionThread::slotEncryptedDone);

Attachment: signature.asc
Description: This is a digitally signed message part.

  • Bug#891253: [src:libkf5ksieve] Please enable TLSv1.2... Maximilian Engelhardt

Reply via email to