Package: searx
Version: 0.14.0+dfsg1-2
Followup-For: Bug #886093

Dear Maintainer,

Joseph Nuthalapati wrote:
> >  SearX currently doesn't start up when run with Python 3 as it tries
> >  to parse the settings.yml file with ASCII codecs.

Johannes Schauer wrote:
> Please provide more support for your theory.

I am encountering what is possibly the same bug here. I will just
provide the error message rather than making up a theory of why it

When I run `searx-run`, I get this error:
Traceback (most recent call last):
  File "/usr/bin/searx-run", line 11, in <module>
    load_entry_point('searx==0.14.0', 'console_scripts', 'searx-run')()
  File "/usr/lib/python3/dist-packages/pkg_resources/", line 572, in 
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3/dist-packages/pkg_resources/", line 2755, 
in load_entry_point
    return ep.load()
  File "/usr/lib/python3/dist-packages/pkg_resources/", line 2408, 
in load
    return self.resolve()
  File "/usr/lib/python3/dist-packages/pkg_resources/", line 2414, 
in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python3/dist-packages/searx/", line 51, in <module>
    raise Exception('settings.yml not found')
Exception: settings.yml not found

I also tried copying the default settings.yml to the folder I run searx
in, like this:
7z x /usr/share/doc/searx/examples/settings.yml.gz
but I get the same error.

-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 4.14.0-3-686-pae (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_GB:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages searx depends on:
ii  python3        3.6.4-1
ii  python3-searx  0.14.0+dfsg1-2

searx recommends no packages.

Versions of packages searx suggests:
pn  nginx                 <none>
pn  uwsgi                 <none>
pn  uwsgi-plugin-python3  <none>

-- no debconf information

Reply via email to