Package: needrestart
Version: 3.0-1
Severity: normal

On some systems I see the following:

  root@clash:~# needrestart -b
  NEEDRESTART-VER: 3.0
  NEEDRESTART-KCUR: 4.15.0-1-amd64
  NEEDRESTART-KEXP: 4.15.0-1-amd64
  NEEDRESTART-KSTA: 1
  NEEDRESTART-UCSTA: 0
  Use of uninitialized value $ucode_vars{"CURRENT"} in concatenation (.) or 
string at /usr/sbin/needrestart line 866.
  NEEDRESTART-UCCUR:
  Use of uninitialized value $ucode_vars{"AVAIL"} in concatenation (.) or 
string at /usr/sbin/needrestart line 867.
  NEEDRESTART-UCEXP:

These are KVM virtual machines without iucode_tool or intel-microcode available.

  root@clash:~# needrestart -bv
  [main] eval /etc/needrestart/needrestart.conf
  [main] needrestart v3.0
  [main] running in root mode
  NEEDRESTART-VER: 3.0
  Failed to load NeedRestart::uCode::Intel: [uCode/Intel] iucode-tool not 
available!
  [ucode] no supported processor microcode detection
  [Kernel] Linux: kernel release 4.15.0-1-amd64, kernel version #1 SMP Debian 
4.15.4-1 (2018-02-18)
  [Kernel/Linux] /boot/vmlinuz-4.15.0-1-amd64 => 4.15.0-1-amd64 
(debian-ker...@lists.debian.org) #1 SMP Debian 4.15.4-1 (2018-02-18) 
[4.15.0-1-amd64]*
  [Kernel/Linux] /boot/vmlinuz-4.14.0-3-amd64 => 4.14.0-3-amd64 
(debian-ker...@lists.debian.org) #1 SMP Debian 4.14.17-1 (2018-02-14) 
[4.14.0-3-amd64]
  [Kernel/Linux] Expected linux version: 4.15.0-1-amd64
  NEEDRESTART-KCUR: 4.15.0-1-amd64
  NEEDRESTART-KEXP: 4.15.0-1-amd64
  NEEDRESTART-KSTA: 1
  NEEDRESTART-UCSTA: 0
  Use of uninitialized value $ucode_vars{"CURRENT"} in concatenation (.) or 
string at /usr/sbin/needrestart line 866.
  NEEDRESTART-UCCUR: 
  Use of uninitialized value $ucode_vars{"AVAIL"} in concatenation (.) or 
string at /usr/sbin/needrestart line 867.
  NEEDRESTART-UCEXP: 

Lack of iucode-tool triggers the $ucode_vars{"CURRENT"} error.  Lack
of intel-microcode triggers the $ucode_vars{"AVAIL"} error.

Bob

-- Package-specific info:
needrestart output:
Your outdated processes:
emacs[6711]

checkrestart output:


-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.15.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: sysvinit (via /sbin/init)

Versions of packages needrestart depends on:
ii  binutils                   2.30-5
ii  dpkg                       1.19.0.5
ii  gettext-base               0.19.8.1-4
ii  libintl-perl               1.26-2
ii  libmodule-find-perl        0.13-1
ii  libmodule-scandeps-perl    1.24-1
ii  libproc-processtable-perl  0.55-1
ii  libsort-naturally-perl     1.03-2
ii  libterm-readkey-perl       2.37-1+b2
ii  perl                       5.26.1-5
ii  xz-utils                   5.2.2-1.3

Versions of packages needrestart recommends:
ii  libpam-systemd  237-4
ii  sysvinit-core   2.88dsf-59.10

Versions of packages needrestart suggests:
ii  libnotify-bin  0.7.7-3

-- Configuration Files:
/etc/apt/apt.conf.d/99needrestart changed [not included]

-- no debconf information

Reply via email to